WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
[resolved] Unable to remove WP Super Cache from plug-in directory (17 posts)

  1. denisehamlin
    Member
    Posted 3 years ago #

    I followed the instructions to manually uninstall WP Super Cache on my hosting site. I am still unable to remove it from the plugin directory and get the following message: This file must be copied into the same directory where WordPress is installed. The file wp-load.php is in this directory I am using the latest version of WordPress.

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. denisehamlin
    Member
    Posted 3 years ago #

    If anyone else has this problem and needs an answer. I ended up deleting it on the hosting site rather than through the WP Panel. This is the only plugin I know of that requires knowledge of hosting to uninstall it.

  3. reviewmylife
    Member
    Posted 3 years ago #

    I don't have anything helpful to add, but I can reproduce this error as too - so it is not just you.

    Not that I'd want to delete it of course as it works well for me :)

  4. thompson84
    Member
    Posted 3 years ago #

    I can reproduce this error too, and had to delete it through an FTP client. To me, that is a fatal flaw, no matter how well the plugin may perform.

  5. denisehamlin
    Member
    Posted 3 years ago #

    @thompson84 - I tend to agree with you. It shouldn't be necessary to have this level of knowledge just to uninstall a plug-in. Although it seems W3TC is no different. I installed that, had serious problems with it - much worse than WP Super Cache - and had to go through a similar procedure to uninstall it. At least by then I knew what I was doing! It seems as long as cache plug-ins are working they're great. All bets are off when they're not!

  6. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    Unfortunately both plugins have to do more work than "normal" plugins to do their job - they need to add some code to the main config file, create a special script in wp-contents and create a cache directory. It's *really* hard to make that foolproof over all the different types of hosting out there.

    Nonetheless, I'm looking at it. The next version should allow you to just disable the plugin on the plugins page. If there are any problems you'll be informed, with instructions on fixing those problems.

    See more here: http://ocaoimh.ie/uninstall-supercache/

  7. denisehamlin
    Member
    Posted 3 years ago #

    @donncha Good to know you're looking for a way to make it possible to uninstall Super Cache through the plugins page. It was quite the learning curve for me to figure it out. It could save other users a number of headaches.

    BTW, of course I went back to your plugin after W3TC failed miserably on my website. It seems having more that one plugin that addresses the speed of a website is better than the all-in-one solution W3TC offers - at least on my site.

  8. JTKay
    Member
    Posted 3 years ago #

    had to delete it through an FTP client.

    I'm lost. I don't have the background to understand where to start here. Is there a step-by-step to help me through?

    I'm getting the same message.

  9. JTKay
    Member
    Posted 3 years ago #

    Just got this in email:
    Dear User,

    WP Super Cache was removed from your blog but the mod_rewrite rules in your .htaccess were not.

    Please edit the following file and remove the code between 'BEGIN
    WPSuperCache' and 'END WPSuperCache'. Please backup the file first!

    Please help. I have no idea where to start.

  10. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    There's a file called ".htaccess" on your server that needs to be edited. If you use ftp to upload files to your site you might have to enable "show hidden files" to show it. FTP to your site and in the root or "/" directory you should find the .htaccess.
    Right click and edit the file if you ftp software allows you to, then look for the 'BEGIN WPSuperCache' and 'END WPSuperCache' text. Delete the lines in-between those lines and upload the file again.

    If you use cpanel or some other web admin interface there should be some means of browsing your site but that's basically what you have to do. Find the file and edit it.

  11. denisehamlin
    Member
    Posted 3 years ago #

    @JTKay ~ Who are you hosting with? If you have a cPanel you'll do fine with Donncha's instructions, if you're with Godaddy probably not so much. They have a complicated interface, not easy for non-techies. (I'm a lot savvier since going through this). I called Godaddy and they helped me out.

  12. JTKay
    Member
    Posted 3 years ago #

    I host with Dreamhost.

    Looking for the .htaccess file but having trouble finding it. My site is http://www.giftideatracker.com. I don't see it in the giftideatracker.com/ file.

    Or I imagine I would have to did into the wp files?

  13. denisehamlin
    Member
    Posted 3 years ago #

    It should be in your root directory where your wp files are.

  14. JTKay
    Member
    Posted 3 years ago #

    Found the file, but it only says this: Nothing about SuperCache

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

  15. denisehamlin
    Member
    Posted 3 years ago #

    Well, there's nothing in htaaccess so you don't need to do anything there then. Not sure what the problem is. The way I resolved my issues was by deleting everything relating to wp cache on the server. There were a couple of files in the content folder. I deleted those. I also deleted the plug-in on the server. (Not in the WordPress Admin Panel).

    The last thing I did was remove the WP_CACHE define from wp-config.php. It looks like this -

    define( 'WP_CACHE', true );

  16. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    JTKay - you don't need to do anything else. The plugin should have checked if there were rewrite rules before sending that message. Fixed now.

  17. JTKay
    Member
    Posted 3 years ago #

    Dreamhost zapped it for me. Good guys over there. Thanks for all your help!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic