WordPress.org

Ready to get started?Download WordPress

Forums

Unable to prevent anomymous comments (6 posts)

  1. nathanlake2
    Member
    Posted 1 year ago #

    Despite all the settings to the contrary, spam comments are constantly being added to my new site. I am the only user and I have set the site so that users must be registered and logged in to comment. Am I missing something? Is there a backdoor that hackers can use to add spam comments? The first comments appeared within 5 minutes of the site being set up.

    Site:
    http://www.thetravelwriters.net

    Environment:
    WP 3.5.1 Multisite (installed 3.5.2 today but have not tested it yet.
    BuddyPress 1.7.2
    Theme: WPMU Blogs MU (problem was occurring before activation of this theme

    Network Admin/Settings/Network Settings:
    Allowing new registration: Registration is disabled (I am the only user on the site

    Site/Settings/Discussion:
    Users must be registered and logged in to comment - CHECKED

  2. Despite all the settings to the contrary, spam comments are constantly being added to my new site.

    Which anti-spam plugins have you tried using?

  3. MarkRH
    Member
    Posted 1 year ago #

    You might see if disabling Allow link notifications from other blogs (pingbacks and trackbacks) in the Discussion settings helps. That's how other things can get into your comments section.

    If you haven't might consider the Akismet plug-in: http://wordpress.org/plugins/akismet/ which seems to catch just about everything. I also happen to use Math Comment Spam Protection http://wordpress.org/plugins/math-comment-spam-protection/ (Granted this one is kind of old but seems to still work.)

    These may not be necessary if you're only allowing registered users to comment and you've turned off registration.

  4. artistforchrist
    Member
    Posted 1 year ago #

    Also go to settings/discussion and make sure in the Before A Comment Section appears section that the An administrator must always approve the comment box is checked.

  5. WP_Plato
    Member
    Posted 1 year ago #

    If you are interested in using a plugin to solve your problem, Maybe you should try using the "Comment E-Mail Verification" plugin.

    It may not be what you are looking for exactly but it works

    Worked for me while i was working on a website on a free host.

    Here is the link to the plugin - http://wordpress.org/plugins/comment-email-verify/

    I hope it works for you.

  6. nathanlake2
    Member
    Posted 1 year ago #

    I have tried unchecking the Allow link notification...

    Will let you know if that works.

    Thanks,

Topic Closed

This topic has been closed to new replies.

About this Topic