WordPress.org

Ready to get started?Download WordPress

Forums

Unable to Post (5 posts)

  1. worldview
    Member
    Posted 7 years ago #

    All of a sudden, unable to post. Can edit php, user settings, fiddle with plugins and theme editor, as well as edit existing posts from Manage menu, but when I create new post and try to save I get a message stating so gently:

    Forbidden
    You don't have permission to access /wp-admin/post.php on this server.
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    Wassup wit dat? Waiting for WAG from host.

    bgr

    Apache/1.3.37 Server at halfwaytoconcord.com Port 80

  2. worldview
    Member
    Posted 7 years ago #

    host says

    No server configuration changes were made on our side recently.
    File/directory permissions appear correct on wp-admin/post.php
    You may want to check the error log of your WordPress installation and contact WordPress support to troubleshoot this issue.

    I ask, where is an error log? that I could use to document problem here?

    bgr

  3. worldview
    Member
    Posted 7 years ago #

    so I found a previous, very friendly, I might add, "unable to post" thread and so followed that trail and edited the .htaccess that looked like

    Options +Includes
    AddType text/html shtml
    AddHandler server-parsed shtml

    I added

    SecFilterEngine Off
    SecFilterScanPOST Off

    so that .htaccess now looks like

    Options +Includes
    AddType text/html shtml
    AddHandler server-parsed shtml
    SecFilterEngine Off
    SecFilterScanPOST Off

    What was it that this patch fixed?

    Is there any danger to doing this?

    Can anyone surmise why this was happening that adding the two lines would fix?

  4. Beej
    Member
    Posted 6 years ago #

    ModSecurity for Apache checks posts for, among other things, SQL injection.

    In my case, having the word "selection" in a post, followed much later by the word "from", must have looked like SQL to mod_security. I got the "Forbidden" error for posts.php.

    Apparently, my server's installation of mod_security was compiled with the -DDISABLE_HTACCESS_CONFIG switch, so I could disable the checking of posts in a .htaccess file in the wp-admin directory with:

    SecFilterScanPOST Off

  5. wongjp
    Member
    Posted 6 years ago #

    Hi all, I had to look this up also after tearing down my post down to the word "selection" first :) This fixed my problem for making the posts, but the glitch will still occur if the Title of the post has "from" and "selection" in it as well..

    I got the following error:

    Forbidden
    You don't have permission to access /log/20070924/wordpress-web-site-glitch-selection-and-from/ on this server.

    I changed the name of the Post Slug (omitted "-selection-and-from" and everything was well.

    Is there a fix for this also that I could plug in to the .htaccess file (I'm not knowledgeable when it comes to modifying .htaccess at all)?

Topic Closed

This topic has been closed to new replies.

About this Topic