WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Unable to modify theme with style.css (7 posts)

  1. amyarabaci2
    Member
    Posted 1 year ago #

    This is my first wordpress. Version 3.5.1. I am using Twenty Twelve theme. My experience with cascading style sheets is limited.

    path1 -- Dashboard -- Appearance -- Editor -- style.css -- Update

    When I use path1 to modify my style.css, I never see any changes to my website's appearance.

    path2 -- Dashboard -- Appearance -- Background

    When I use path2 to modify my website, I see changes.

    I found an article that told me to use a child theme so I installed a child theme and realized (after I successfully installed and activated the child theme) that the css examples don't work.

    I selected and cut all the code and updated a blank style.css. The website looks unchanged.

    What am I doing wrong? What is the proper way to edit or update changes to style.css?

    Thanks.

  2. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Do you have any caching enabled on your site. Posting a link to your site would also be useful.

  3. amyarabaci2
    Member
    Posted 1 year ago #

    A link to my site

    I will check to see if caching is enabled. By caching, do you mean my web host account?

  4. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    It's usually a plugin. But you don't have a child theme active on that site, so you need to go back to that step one. Did you follow this?

    http://codex.wordpress.org/Child_Themes

  5. amyarabaci2
    Member
    Posted 1 year ago #

    I moved back to twenty twelve to delete the contents of style.css to see what would happen.

    I've activated the child theme again.

    The background color is a shade of green now and that's a change made by path 2. There isn't any customizing code in the child theme now.

  6. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    It's working fine in Firebug - try adding this to the style.css file (child) - and clear your browser cache:

    h1 {
        color: red;
    }
  7. amyarabaci2
    Member
    Posted 1 year ago #

    Thank you. It was a browser cache problem.

Topic Closed

This topic has been closed to new replies.

About this Topic