WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Unable to login to new site. (13 posts)

  1. James W. Lane
    Member
    Posted 1 year ago #

    I am running a MU with eight sites running on it. Seven of the eight sites have been installed and activated prior to version 3.5 coming out.

    The only two plugins I have activated over the network are: WordPress MU Domain Mapping & WPMU DEV Dashboard.

    When I added a new site today its load up fine but when I try and login to the wp-admin it gives me the wp-login.php.

    I type the admin username and password and it keeps reloading this http://newsitename.com/wp-login.php?redirect_to=http%3A%2F%2Fnewsitename.com%2Fwp-admin%2F&reauth=1

    I try to login to the other seven sites they work fine.

    I tried disabling the WPMU DEV Dashboard still does the same thing.

    I have deleted the site and re-added it, same result. Tried different admin names, still same result.

    The site its self is running no plugins and twenty twelve. I have never been able to login.

    My .htaccess looks like the following

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

    I am generally pretty good at these things but this one has me stumped.

  2. James W. Lane
    Member
    Posted 1 year ago #

    I am still trying to debug the situation.
    I have attempted these steps still with no success.

    1) I edited my wp-config.php salt/hashes
    2) Dump your cache.
    3) Delete your cookies.
    4) Updated my .htaccess to

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) wp/$2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ wp/$2 [L]
    RewriteRule . index.php [L]

    5) Check that my wp-config.php defines multisite correctly.

    define('WP_DEBUG', false);
    define('WP_ALLOW_MULTISITE', true);
    define('SUNRISE', 'on'); // Enable Domain Mapping JWL Nov 29 2012
    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', true );

    Its still allows me to login to the admin for the main site and six other domains that I had running prior to the 3.5 update.

  3. Is this new site a mapped domain or a subdomain?

  4. James W. Lane
    Member
    Posted 1 year ago #

    Its a mapped domain, the site shows up fine like the rest. But the login just will not work. It wont even give me a error just a page refresh and thats it.

  5. Did it work as a subdomain?

  6. James W. Lane
    Member
    Posted 1 year ago #

    Sorry for the delayed response, I moved for the new year.
    When is was a subdomain it didn't work also. It's confusing because six other sites work fine with the exact same setup. Just this one that I just created won't let me login to the admin.

  7. Okay. That's your problem. If it doesn't work as a sub domain, no way on the green earth will it work mapped :)

    Verify that the subdomain is set up correctly in DNS and on your server. If the subdomain doesn't resolve to your server's IP, that's what's going on.

  8. James W. Lane
    Member
    Posted 1 year ago #

    I tested DNS before posting to the forums, Its not that I am getting a 404 or any other type of error. The website loads and the login also load perfectly. Just when I type in the login and Pass and click login it just refreshes the login page. No error no nothing. Its resolving to the proper server and all my other sites are working fine. Just this certain one will not let me log in at all.

  9. Flush your browser cookies.

  10. James W. Lane
    Member
    Posted 1 year ago #

    Mika,
    Like I have said in my second post on this thread I have:

    1) I edited my wp-config.php salt/hashes
    2) Dump your cache.
    3) Delete your cookies.
    4) Updated my .htaccess to
    5) Check that my wp-config.php defines multisite correctly.

    I have also tried to log in using Safari ,Chrome , Firefox, Opera on both windows and mac computers.

    I have still yet been able to log into the new site.

  11. Obviously if it works for all other sites but this one, it's not .htaccess or wp-config.

    But. Are you still testing on the mapped domain or the unmapped? This does matter, cause honestly, double-debugging both a possible goofed mapping AND a weird WP issue, isn't work the headache ;) Start from as step one as possible, then complicate matters.

    You said this happened on the subdomain as well. Does it happen on any others? Like can you make another subdomain and test that?

    Did you perhaps reuse an old subdomain?

  12. James W. Lane
    Member
    Posted 1 year ago #

    Testing on the mapped domain at the moment due to a non WordPress project is running. I am finishing off a project this week, I will have time after this weekend to dig into it. It doesn't happen to any others sites, thats what's been confusing me. I will create one next week and test that. I didn't reuse a Subdomain. I will work on it Monday and see what I get. I will post here to let you know the result.

  13. James W. Lane
    Member
    Posted 1 year ago #

    I created another site, it worked properly. So I tested the original site again. Its now working properly. Don't know what creating another site fixed, but they both are working fine.

Topic Closed

This topic has been closed to new replies.

About this Topic