WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Unable to login on WP - Bad request (11 posts)

  1. sandra.apperloo
    Member
    Posted 11 months ago #

    Hello there,

    I can't login to my wordpress dashboard/account. Yesterday I changed my e-mail adress in the admin panel of my dashboard. I also added the url of my website in the user contact info tab and I have a feeling one of these might have something to do with it. But I didn't adjust the URL or anything.

    The message i'm getting when logging in on chrome is:

    Bad request
    Your browser sent a request that this server could not understand.
    Apache/2.2.16 (Debian) Server at http://www.artisticmoods.com Port 80

    On Firefox it says:

    Forbidden

    You don't have permission to access /wp-login.php on this server.
    Apache/2.2.16 (Debian) Server at http://www.artisticmoods.com Port 80

    Things i've tried so far:

    - Changed back to my old email adress on php.admin.
    - Changed my password via a wordpress email request.
    - Deleted cookies
    - Turned off my firewall
    - Deactivated plugins
    - Screamed

    Nothing has worked so far, not even screaming. I'm getting quite desperate as I need to be working on my website tonight.

    Is there anything I might be missing here? Unfortunately I'm not really a wordpress/code wizzard so I don't really know if there's anything wrong with any codes. Is it possible for anyone else to have a look in my admin to spot the problem?

    Thank you in advance for helping me out!

  2. nullvariable
    Member
    Posted 11 months ago #

    I was able to access the login page for your site at http://www.artisticmoods.com/wp-login.php just fine and received the expected error message when I entered fake login information. I believe you may have an issue with your Cookies or Cache. It's also possible that you have a security plugin that is disabling access. Some security plugins will block your IP address if you enter the wrong password more than a certain number of times. Try using a Chrome Incognito window and see if you can login that way. If that doesn't work, access your site and rename the plugins folder to something else (plugins-disabled or something like that) This will disable all of your plugins, then test to see if you can login. If you can login, then great and you know that one of the plugins was at fault. You will need to rename your plugins directory back to "plugins" to be able to re-enable your plugins in the WordPress administration screen.

  3. Tara
    Member
    Posted 11 months ago #

    Also try:

    - To rule out any theme-specific issue, try switching to the unedited default theme for a moment using the WP dashboard. If you don't have access to your admin area, you can switch to the default theme by renaming your current theme's folder in wp-content/themes and adding "-old" to the end of the folder name using via FTP or SFTP or whatever file management application your host provides. Alternately, you can remove other themes except the default theme. That will force your site to use it.
    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems (because the hooks remain unless plugins completely removed or some plugins stick around in cached files. So by renaming the folder, you break them and force them inactive). Read "How to deactivate all plugins when you can't log in to wp-admin" if you need help.
    - If the problem persits, contact your hosting provider. They may made some security related changes to the server.

  4. sandra.apperloo
    Member
    Posted 11 months ago #

    Hi there,

    Thanks for your quick response. I've tried logging in on incognito but unfortunately it doesn't work. I had already deactivated the plugings but that didn't work either. Is there any other security thing that might be blocking access? I've also tried logging in on my Ipad but same problem there..

    Thanks again,
    Sandra

  5. Tara
    Member
    Posted 11 months ago #

    I had already deactivated the plugings

    - First, deactivating plugins one by one isdifferent than "resetting the plugin folder" as I suggested in my previous reply. Have you attempted to "resetting the plugin folder"?

    - Second, have you attempted switching to the default theme as i suggested in my previous reply?

    - Third, Have you attempted to contact your hosting provider as I suggetsed in my previous reply?

  6. nullvariable
    Member
    Posted 11 months ago #

    As Tara mentions, this is most likely a security issue with your hosting provider. If they're hard to contact, try using a different network to access the site and see if that works. If it does, then your IP address is being blocked by them.

  7. sandra.apperloo
    Member
    Posted 11 months ago #

    Thanks for your help & quick responses! I was responding to nullvariable as I hadn't seen your message yet, Tara. But i'm going through the steps you suggested and see if I can contact the hosting provider otherwise. I'll let you know how it goes!

  8. sandra.apperloo
    Member
    Posted 11 months ago #

    I still can't tell what caused the problem, but after trying several things and leaving it to rest for a while I just found out that it's working again.

    Thanks for your help! Have a great sunday!
    Sandra

  9. Tara
    Member
    Posted 11 months ago #

    Glad you resolved it :-)

  10. sandra.apperloo
    Member
    Posted 11 months ago #

    Just got a message back from my hosting provider. Turns our they had blocked it!

  11. Tara
    Member
    Posted 11 months ago #

    That was my suspicion! :-)

Reply

You must log in to post.

About this Topic