WordPress.org

Ready to get started?Download WordPress

Forums

Len Slider
[resolved] Unable to load images (10 posts)

  1. blasterspike
    Member
    Posted 1 year ago #

    Hi,
    first of all thank you for your efforts in making such a great plugin!
    And most of all, for keeping it free :)

    The problem I have encountered is that I have a different behaviour of the plugin using Firefox or Chrome and on both javascript doesn't work well.

    WordPress 3.5.1
    LenSlider 2.0.7

    On Firefox 19.0.2 on Windows
    If I add a new slider, I can see the box "Photo from your computer or media library" but if I click it, nothing happens.

    If I click on the "Add new banner" button, I get the wait running circle but nothing happens.

    On Google Chrome 25.0.1364.152 m on Windows
    If I add a new slider, I can click the box "Photo from your computer or media library". The "LenSlider Media Manager" window appears and I am able to load an image.
    I can see the image uploaded in the banner box and it shows me the path
    /wp-content/uploads/eb67913691-4b74015ac6.jpg
    but I am not able to change
    WIDTH × HEIGHT (PIXELS):
    It shows 500x200px of defaults and are not correct for the uploaded images.
    Also, I am not able to change the "tab" to switch to "Text only", YouTube video, Vimeo Video.

    Here, if I select "Add new banner", a new banner is added.

    I have just installed the plugin, so I'm just trying to add the very first banner.
    I know it is a javascript plugin but I don't know how to debug it.

    If you need more information to debug the problem, please let me know :)

    Thanks

    http://wordpress.org/extend/plugins/len-slider/

  2. Igor Sazonov
    Member
    Plugin Author

    Posted 1 year ago #

    hi, blasterspike!
    it was really bug for firefox, sorry, just tagged 2.0.8. Check it

  3. therealro
    Member
    Posted 1 year ago #

    This works now

  4. blasterspike
    Member
    Posted 1 year ago #

    Hi,
    thanks for updating the plugin!
    Now on Firefox it has the same behaviour as on Chrome.
    It shows the image but I am unable to change
    WIDTH × HEIGHT (PIXELS):
    and I can't switch on another tab.

    If I click Delete on the image, the confirmation box appears
    "Are you sure?"
    If I click Yes, the loading bar appears on the image but it doesn't anything, the image is still there.

    Another question:
    why if I select an images with already the desired width and height, LenSlide creates another image
    "Maked and using for LenSlider ada2b930c6 banner. Dont delete from media library."
    Why?

    Thanks again

  5. blasterspike
    Member
    Posted 1 year ago #

    Another problem is that I'm unable to save the banner as if I set
    Title = Manual
    and I set a title, when I click save, the red border appears around the Title box as I haven't entered anything.

  6. Igor Sazonov
    Member
    Plugin Author

    Posted 1 year ago #

    Hi, thanks for problems report!
    It shows the image but I am unable to change
    WIDTH × HEIGHT (PIXELS):
    and I can't switch on another tab.

    yes you cant because if content is ready for banner - width and height are disabled, you need to delete it for unblocking. this is for safety.

    If I click Delete on the image, the confirmation box appears
    "Are you sure?"
    If I click Yes, the loading bar appears on the image but it doesn't anything, the image is still there.

    thanks! going to fix it!

    Another question:
    why if I select an images with already the desired width and height, LenSlide creates another image
    "Maked and using for LenSlider ada2b930c6 banner. Dont delete from media library."
    Why?

    because width x height is for resizing your current image. If you talking about you upload a new image and then it resized - yes, i need to make a helper that will check for a just uploaded image, but i thinking now how to do it.

  7. blasterspike
    Member
    Posted 1 year ago #

    yes you cant because if content is ready for banner - width and height are disabled, you need to delete it for unblocking. this is for safety.

    OK, so I have to set width and height before selecting the image?
    Even if I set the correct dimensions, a new image is created by LenSlider with title
    "Maked and using for LenSlider ada2b930c6 banner. Dont delete from media library."

    Please also have a look at the problem that I'm unable to say.

    Thanks again for your helpfulness! :)

  8. blasterspike
    Member
    Posted 1 year ago #

    Even with version 2.0.9 the problems are the same.

  9. Igor Sazonov
    Member
    Plugin Author

    Posted 1 year ago #

    Hi, title like "Maked and using for LenSlider ada2b930c6 banner. Dont delete from media library." is only for WP media library. LenSlider makes for every banner an own attachment and uses id of the ona as a key for array item, so when you will delete banner via lenslider this attachment will be deleted too.
    What is problem in 2.0.9 now? Firefox?

  10. Igor Sazonov
    Member
    Plugin Author

    Posted 11 months ago #

    hope resolved

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic