WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] unable to install on localhost (16 posts)

  1. bizrichard
    Member
    Posted 1 year ago #

    tried installing wordpress on localhost - running the set-up failed to create the wp-config file, so edited it manually, but when running the config file, get error report "can't contact the database server at localhost". I've checked database name with config file and correct - so any ideas of what next please?

  2. ClaytonJames
    Member
    Posted 1 year ago #

    Some things you can check:

    - Confirm that MySQL is running and you can connect to using your database administration tools.

    - Check the database-user username and password you assigned when you created the database for WordPress... are those correctly entered in wp-config as well?

    - Did you remember to assign that user privileges on the WordPress database you created?

  3. bizrichard
    Member
    Posted 1 year ago #

    MySQL running ok, but the database I created for wordpress has no tables - I assumed the installation process would do that - is this a manual process that I need to tackle separately?

  4. esmi
    Forum Moderator
    Posted 1 year ago #

    No. You are correct in that the install process creates the tables for you. As Clayton said, it sounds like there's a problem with your database host name. It's obviously not localhost.

  5. bizrichard
    Member
    Posted 1 year ago #

    Your clue about the database had me digging around - seems like I have IIS installed, which sets up localhost on startup, and so localhost is already running correctly. My installation of xampp and php etc is being bypassed and hence the database not being connected - or I assume this to be the position - trying to get my head around this one at the moment - any ideas?

  6. ClaytonJames
    Member
    Posted 1 year ago #

    Disable IIS ?

  7. bizrichard
    Member
    Posted 1 year ago #

    apologies for delay in responding - a bit busy work wise at the moment so having trouble finding time to attend to this problem.
    I've now disabled iis, uninstalled xampp, reinstalled latest version of xampp, but now can't get apache to run?? seems to be a port conflict on 80 and 443. does apache need to run?

  8. ClaytonJames
    Member
    Posted 1 year ago #

    seems to be a port conflict on 80 and 443

    That's something that usually pops up when there is more than one web server or port 80 based application running at the same time. In this case, it would certainly be caused by IIS and Apache running at the same time.

    does apache need to run

    Yeah... That's going to be pretty important. Could you give us some quick info? Maybe we can put you on the good foot with a little more information...

    What Windows OS are you installing XAMPP on, and was there a legit reason for the IIS web server being up and running prior to installing XAMPP?

    e.g.. are there other web-based service running on the machine?

  9. bizrichard
    Member
    Posted 1 year ago #

    Running windows 7. I don't recall ever installing IIS or having a reason to - must have been on original installation (could it be something to do with this bein a 64 bit machine??). I'm not aware that there are any other web-based services running - I often don't even connect to the web when using this machine (a laptop) and all works fine.

    Prior to uninstalling xampp a few days ago, apache was running okay (using xampp control panel). Took it out to try and find out if/why mySQL was already running, and what was preventing wordpress from connecting to the database.

    So seem to have messed up something along the way?

  10. ClaytonJames
    Member
    Posted 1 year ago #

    I can't say that I've ever come across a Win 7 machine where IIS was installed and running by default, but certainly that could still be an issue. You may want to do a quick Google search on disabling or removing IIS in Win 7 to make sure all the components are completely inactive or uninstalled. You definitely shouldn't have two web servers running on port 80 at the same time.

    Possible solutions:

    Try removing IIS completely if you have no need for it. Completely uninstall XAMPP, and then do a little clean up to make sure you get anything it may have left behind. Try a reinstall of XAMPP, paying particular attention to any installation dialogs and options along the way (install as a service, open firewall port, etc..).

    You might also want to take a look at some of the guides and tutorials out there for XAMPP. Maybe something you find will lead to a clue about why it's giving you a tough time. XAMPP "how to" windows 7

    All things being equal, that should give you a working installation where you can test apache, mysql, and php to make sure they are all operating correctly before setting up WordPress.

    If you still see no success with XAMPP, you might try WampServer. I've had very good luck with it on Win 7. You just need to install MS visual C 2010 redistributable first on Win 7. Just make sure any packages you select are for your platform. (64bit).

  11. bizrichard
    Member
    Posted 1 year ago #

    I've removed xampp completely now - but having trouble getting rid of IIS - I've disabled it per earlier suggestion but, whenever I insert 'localhost' into the browser, IIS comes up every time!

    As you suggest, I will find a way of uninstalling it (doesn't show up in the programs directory)?

  12. bizrichard
    Member
    Posted 1 year ago #

    It seems that I need to 'turn off IIS' in windows features - done this, re-installed xampp 1.8 and currently apache is working (no conflict with ports reported) - now to revisit the WordPress installation!

  13. bizrichard
    Member
    Posted 1 year ago #

    successful at last - wordpress up and running locally - thanks to all

  14. ClaytonJames
    Member
    Posted 1 year ago #

    Nice! Glad you got it sorted out.

  15. amrjays
    Member
    Posted 1 year ago #

    I set up local host & made every thing alright but I changed the word press address URL and site address from http local host to http://www.
    so I cant entered to my word press And give me error message in Google search I don't know what I do

  16. bizrichard
    Member
    Posted 1 year ago #

    Thanks Clayton - lost my internet over the weekend due to ip technical issues, but presumably I now mark this topic as resolved. Thanks again to you and Isme for your timely and patient help.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags