WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Unable to get Database to connect to WordPress (16 posts)

  1. 8web
    Member
    Posted 4 years ago #

    Building new blog on site hosted by Network Solutions (small UNIX). Have uploaded WordPress files to server, added database login info, etc but when I try to install it (browse to this URL):

    http://www.entelliworld.com/blog/wp-admin/install.php

    I get the error message:

    "Error establishing a database connection"

    Network Solutions provides a MySQL database with a phpMyAdmin console. From the console I can see that it reognizes the DB name and DB user name I assigned. However, it says there are no tables in the DB. Thought this was automatic but see I'm missing a step somewhere -- how do I correct this?
    Thanks,
    Frank
    Aug 9, 2009
    ..............................

  2. @mercime
    Volunteer Moderator
    Posted 4 years ago #

    # Are you sure that you have typed the correct hostname?
    Check also with Network Solutions, they have good customer service.

  3. 8web
    Member
    Posted 4 years ago #

    Thanks for the quick reply. Yes, have double-checked the login info it is correct -- it shows up correct in the phpMySQL console etc. I have contacted Network Solutions and they tell me I'm on my own regarding connecting WordPress to their MySQL DB. I have read/reread and checked/rechecked the detailed WordPress install instructions -- same result. Am missing a simple step no doubt. Any other ideas?
    Frank
    Aug 9, 2009
    .....................

  4. @mercime
    Volunteer Moderator
    Posted 4 years ago #

    -- If you have an FTP program like Filezilla, go to where your wp-config.php is and right click on wp-config.php and click View/Edit and make sure that you have the details correct.
    -- In some servers, one fix is to delete given user in cpanel and re-create a new one
    -- Search of WordPress forum on this topic reveals most often the host name and/or username and password errors.

  5. 8web
    Member
    Posted 4 years ago #

    Yes, have verified data in FTP program (WS_FTP_Pro) is correct -- read more of the forum comments you suggested -- still a no go --

    Thanks for trying Mercime --

    Best,
    Frank
    Aug 9, 2009
    ....................

  6. smuffle89
    Member
    Posted 4 years ago #

    it might have something to do with your .htacess file. did you change anything on it?

  7. iwally
    Member
    Posted 4 years ago #

    I experienced the same problem. After searching over the search engines, I find a usefull information :
    if you're using socket connection rather than IP to your database, you should check this line in your php.ini :
    mysql.default_socket = /tmp/mysql.sock (default install, see if the path to the file is OK)
    Then, restart your web server. Let me know if that helped.

  8. 8web
    Member
    Posted 4 years ago #

    No, I haven't changed anything with the .htaccess file -- should I? What do you suggest?
    Thanks,
    Frank
    Aug 9, 2009
    ......................

  9. 8web
    Member
    Posted 4 years ago #

    For iWally:
    Thanks for the reply. Am assuming the php.ini file is located on the server not in the WordPress files, right? I do not have direct access to the server files with this domain as it is hosted on a shared server with Network Solutions. I've already got a couple of support tickets open on this with NSI but they've not neen that helpful so far. Will keep you suggestion in mind going forward -- thank you!
    Frank
    Aug 9, 2009
    ......................

  10. huffy2009
    Member
    Posted 4 years ago #

    I am looking at wordpress as a CMS website for a friend. I have installed the windows XAmpp package from apachefriends and can get Joomla to install and test. WordPress cannot find the database which I have set up in the wpadmin...cannot connect. I am using localhost for the server and it cannot find it. I have changed the config file as instructed and it cannot connect. Does anyone have any solutions on this. phpMyDmin shows the user is correct, the db is correct, and shows the server as localhost.

    Does the ABSPATH have to set with the path?? In the sample config file it does not show a place for editing as the other lines of code indicated. Any help would be appreciated.

  11. 8web
    Member
    Posted 4 years ago #

    For huffy2009:
    Altho it seems your WP is installed on a Windows server the symptoms you have are exactly the same as I am having trying to install WP on a UNIX/Linux server. My hosting company's database console (phpMyAdmin) shows it has received the correct database name, user name, and password from WordPress -- and it uses Localhost.

    Yes, am curious about the ABSPATH as well -- but did not see anything in the WP install instructions about adding input data for path, etc.

    Sounds like we both are having the same problem -- thanks for replying -- will let you if I hear anything --
    Best,
    Frank
    Aug 9, 2009
    .................

  12. whooami
    Member
    Posted 4 years ago #

    neither of your issues have anything to do with that path setting.

    that setting is for files.

    database issues are VERY straight-forward, and the install.php is NEVER wrong in diagnosing mysql connection issues.

    For netsol, see if this doesnt help:

    http://www.lunartcorp.com/blog/?p=11

    that article is dated, so here:

    http://www.google.com/#hl=en&q=network+solutions+wordpress+installing&aq=f&oq=&aqi=&fp=flbC24gbdiA

  13. tanchiahuei
    Member
    Posted 4 years ago #

    if you used the wp-config-sample.php file to create your wp-config.php file, i noticed that there is a missing ?> at the end of it. when i added this, it fixed part of my installation (but i'm still having other problems myself).

  14. whooami
    Member
    Posted 4 years ago #

  15. 8web
    Member
    Posted 4 years ago #

    For whooami, huffy2009, iwally and all others:

    Got it -- it's working. The source whooami gave above was the one -- all it took was inputting the site IP address as the Localhost -- and it worked!

    Thanks to all --
    Frank
    Aug 9, 2009
    ..................

  16. 8web
    Member
    Posted 4 years ago #

    Suggestion to WordPress staff: -- that you add a short blip in somewhere in the WP installation instructions about the Network Solutions (NSI) hosting requirement to input the host site IP address in place of 'Localhost' when connecting to the database etc.

    Thanks again to you and all the forum members who helped solve this issue for us!
    Best,
    Frank
    August 10, 2009
    .................................

Topic Closed

This topic has been closed to new replies.

About this Topic