WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Unable to get back into admin (15 posts)

  1. kkudrna
    Member
    Posted 3 years ago #

    I started a new blog and realized that when I tried to view the URL, a "this website is coming soon" page appeared. Realized my FTP path had "wordpress" on it. I thought I would be smart and fix the FTP path issue by going into WordPress admin for my blog and remove "wordpress" from the two URL entries in there and now I can't even get into my admin account anymore. Please help!

  2. James Laws
    The WP Ninjas
    Posted 3 years ago #

    I would suggest putting the correct address back into that section through phpmyadmin or whatever you use for your database management.

  3. kkudrna
    Member
    Posted 3 years ago #

    I managed to get into the phpmyadmin but I'm sure where to go next.

  4. James Laws
    The WP Ninjas
    Posted 3 years ago #

    Under your wp_option table you will want to edit the addresses for your site are correct. If not edit them to be the actual addresses.

  5. govpatel
    Member
    Posted 3 years ago #

    "this website is coming soon"

    You must be getting this message on your domain name as there must be place holder index.html there but you have installed your wordpess in a folder so you should be able go to your website using
    http://your domianname.com/wordpress

  6. kkudrna
    Member
    Posted 3 years ago #

    Thanks, I was able to get back into admin by going to wp_option and putting "/wordpress" back into my url.

    Now I need to figure out how to properly fix it so people can type in my URL without the "/wordpress" at the end.

  7. govpatel
    Member
    Posted 3 years ago #

    Log in admin change the urls to your domain name Settings General do not try to go on your website as you will not be able to go on there.

    Log in on server or ftp and move contents of wordpress folder to your root(public_html if you have cpanel)and then try and go on your website with your domain name.

  8. James Laws
    The WP Ninjas
    Posted 3 years ago #

    If you are not using the multisite functionality then the easiest way is to go to your settings and change your url to the main domain without the /wordpress and leave the install address with the /wordpress.

    Then move your index.php and .htaccess file from the wordpress directory to the root directory.

    Then you would still login at yourdomain.com/wordpress/wp-admin/ but people who visit your site would simply visit yourdomain.com.

    Much easier than moving all of your files to the root directory.

  9. govpatel
    Member
    Posted 3 years ago #

    By doing that I think you need to change your index.php in root

    Change the line that says:
    require('./wp-blog-header.php');
    to the following, using your directory name for the WordPress core files:
    require('./wordpress/wp-blog-header.php');

  10. James Laws
    The WP Ninjas
    Posted 3 years ago #

    Yes, govpatel is correct. Sorry I neglected to mention that.

  11. kkudrna
    Member
    Posted 3 years ago #

    James: I assume you mean general settings in wordpress admin. If so, the wordpress url has the domain.com/wordpress and the site address has domain.com. I'm not sure what you mean't by the install address.

    I'm assuming you both are then talking about the file manager in the hosting control center for the rest of the process. What I think is the root directory is labeled "html" I see index.php under the wordpress directory but not .htaccess.

    wp-blog-header.php under the wordpress directory. Are you saying that all I have to do is rename it wordpress/wp-blog-header.php?

    Thanks,

  12. James Laws
    The WP Ninjas
    Posted 3 years ago #

    It sounds like your settings are correct. You may not have an .htaccess file if you haven't setup pretty permalinks yet or are perhaps on a windows server.

    Simply open and edit the index.php file.

    Change the line that says:
    require('./wp-blog-header.php');
    to the following, using your directory name for the WordPress core files:
    require('./wordpress/wp-blog-header.php');

    Save this file and then using your file manager, move it to your html directory or whatever directory is the next one back from the wordpress directory.

    This will make your WordPress site load when some one visits yourdomain.com while you will still be able to login at yourdomain.com/wordpress/wp-admin

  13. govpatel
    Member
    Posted 3 years ago #

    The index.php file that is in root open that in a editor at you will see

    require('./wp-blog-header.php');

    this good if you have all wordpress files and folders in same folder.

    Since you have them in wordpress folder you need to edit to

    require('.wordpress/wp-blog-header.php');

    so that it can find files and folders.

    You might not see .htaccess as its hidden file but it is there.

  14. kkudrna
    Member
    Posted 3 years ago #

    Thanks guys. It was a success! Plus I learned a too.

    Kevin

  15. govpatel
    Member
    Posted 3 years ago #

    Great Glad to hear your problem is solved.

Topic Closed

This topic has been closed to new replies.

About this Topic