WordPress.org

Ready to get started?Download WordPress

Forums

[closed] Unable to edit themes in WP 2.8 (12 posts)

  1. WoodiE
    Member
    Posted 5 years ago #

    When I log into WP-Admin and go to Appearance > Editor and select ANY file in the theme the page loads completely but the text box to edit my theme is completely grayed out.

    I am an administrator, in fact the only user.

    I've tried re-uploading the wp-admin folder again via FTP and have tried disabling all my plugins. Still nothing seems to work, the editor box remains grayed out.

    Any suggestions?

  2. esmi
    Forum Moderator
    Posted 5 years ago #

    Have you tried changing permissions on the wp-content/themes folder?

  3. WoodiE
    Member
    Posted 5 years ago #

    The folder and files have always been set to 777 and I've never had problems editing the them prior to the upgrade. However, I went ahead and again CHMOD them to 777 only to get the same results.

    I've also noticed that the "Update File" button on the editor page is shown so wp knows the files are editable, just not letting me edit them.

  4. esmi
    Forum Moderator
    Posted 5 years ago #

    You could try deactivating all plugins to see if this resolves the problem.

  5. WoodiE
    Member
    Posted 5 years ago #

    Already stated in the very first post that I've tried this.

  6. esmi
    Forum Moderator
    Posted 5 years ago #

    Sorry - missed that. Other thoughts:
    - if you're running Google Gears disable it.
    - try switching themes
    - try another browser to rule out browser-specific issues
    - even better, try another machine (hey - this affected me once)
    - re-upload fresh copies of wp-admin and wp-includes

  7. mobileforesight
    Member
    Posted 5 years ago #

    I have a similar problem. Compared to WordPress 2.7.1 you have added a new function in WordPress 2.8 for the Dashboard panel: Appearance->Editor.

    In WP 2.7.1 the code in the editor was just a plain text file. In 2.8, a JavaScript (I believe) adds line numbers, color markings for code, etc. inside the editor. When I go to that page and click to edit on the rather large Header.PHP file for my theme Atahualpa, the browser freezes for more than a minute before the JavaScript is done loading and sometimes the browser crashes completely. That problem I can live with but the total disaster is that the script also randomly refuses to accept my edits.

    This is a strong indication that the macro responsible for line numbers, color etc, in the editor is badly coded and inefficient. As it can’t be turned off there is no way to handle this problem.

    I STRONGLY RECOMMEND THAT WORDPRESS MAKES THIS MACRO AN OPTION IN WP 2.8.1 AND HAVE IT DEACTIVATED AS DEFAULT, ALLOWING THE USERS TO TURN IT ON INSTEAD (e.g.:“guided editing”).

    (In that way, the acute problem is solved, and the macro can be improved without time pressure.)

  8. Sherry Dedman
    Member
    Posted 5 years ago #

    Any fix for this? I'm having the same probs. Is 2.8.1 the answer?

    Thanks.

    -Sherry

  9. brianan
    Member
    Posted 5 years ago #

    hi there,
    yes me too, having the same problem. could anyone help????? pleaseeeee
    Brianan

  10. gyutae
    Member
    Posted 5 years ago #

    I had this same problem as well where every box in the Edit Themes section was greyed out..

    Then I realized that the problem only happens when I'm in the non-www version of my URL. For example, http:// domain.com/wp-admin. Try adding the www (or vice versa depending on which version you specified for your blog).

    That should do it.

  11. brianan
    Member
    Posted 5 years ago #

    hi guys,

    seems like WordPress.org doesn't bother to answer or try to resolved our problems.

  12. abrahkev
    Member
    Posted 4 years ago #

    I have just deactivated the plugins that I installed and yesss! it works,
    thanks a lot esmi

Topic Closed

This topic has been closed to new replies.

About this Topic