WordPress.org

Ready to get started?Download WordPress

Forums

unable to edit a specific post (3 posts)

  1. fikrimvar
    Member
    Posted 5 years ago #

    while trying to edit a post by
    post.php?action=edit&post=27
    this error is displayed
    Fatal error: Maximum execution time of 30 seconds exceeded in ...\wp-includes\wp-diff.php on line 311
    I believe my site has been hacked and post might contain a large amount of invisible text and that is why I am trying to edit at the first place.

    Can we disable the diff ability?
    Thanks

    P.S. This large amount of text also existed in other parts of a page, however I got rid of them by updating wordpress and theme.

  2. fikrimvar
    Member
    Posted 5 years ago #

    so I guess this means no.
    as a developer myself, may I suggest that whenever you start a new feature, first thing to do is to put an option to disable it.

  3. flyfisher842
    Member
    Posted 5 years ago #

    10/20

    I too am having this problem. It is because I had to make 28 revisions to the published post to get it almost right. It needs one more revision to display properly.

    Either I should be able to disable this diff check or be able to extend it long enough for load process to cycle thru the revisions to find the most current one.

    Or better yet, improve WP so it automatically goes to the post revision with the latest time stamp.

    I would appreciated a reply.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.