WordPress.org

Ready to get started?Download WordPress

Forums

unable to create directoty messgae (5 posts)

  1. kate enf
    Member
    Posted 6 years ago #

    Hi - sorry - i have searched the Forum but cant find an answer to my specific image uploading query.

    what happens is i get the message: Unable to create directory /../../../../../../../../../../../../../../../../../tmp. Is its parent directory writable by the server?

    I've been in touch with my web host and they say that have i have permissions to two levels down - i.e. root > blog - but not any further, and obviously wp-content is the next level down.

    (I've cleared my cache, i'm using firefox)

    how do it resolve this?

    i could upload images no problem prior to the upgrade.

    (the upgrade is great by the way!b)

  2. maotouying
    Member
    Posted 6 years ago #

    I am having the same problem with
    WordPress 2.0.3
    PHP Version 4.3.10
    SuSE 9.3.1-3
    Plesk 7.5.4
    Apache/2.0.53 (Linux/SUSE)

    :-(

  3. IainPurdie
    Member
    Posted 6 years ago #

    I've had similar problems with 2.5 on one host, but not on another. Changing permissions has made no difference.

    One thing to try, which did work for me:

    1) Ensure you are not trying to upload the files into a folder that already exists. Let the system create a new one. It does mean that your files may be separated from the old ones, but that's a small price to pay to get it working!

    2) Make sure your path for the directory does *not* begin with a "/". This will ensure that you create the directory within the WordPress folder structure to which you should have access.

  4. maotouying
    Member
    Posted 6 years ago #

    Hi Iain (& Kate),
    please : how have you done this trick ?

  5. maotouying
    Member
    Posted 6 years ago #

    Hi Iain & Kate,
    silly me :
    1. Login as admin (or whatever your super-user is called)
    2. Go to Options -> Miscellaneous
    3. Check : Store uploads in this folder
    4. Restore : wp-content/uploads (this is where I have found that /../tmp thing)
    5. Check "Organize my Uploads ..."
    6. Hit "Udate Options"
    This worked for me, thanks a Million or even more ...
    uhu

Topic Closed

This topic has been closed to new replies.

About this Topic