WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Unable to create directory /wp-content/uploads. Is its parent directory writable (14 posts)

  1. jsandifer
    Member
    Posted 5 years ago #

    I have tried everything I can find to make this go away. Including changing permissions to 777, Settings>Misc then changing to not having it in months, I have made sure that I don't have anything in the /uploads folder. I can manually add an image to a post with : <img src="http://brandedblog.com/wp-content/uploads/picture-52.jpg" alt="" width="692" height="461" />

    I am not an expert, but feel like I have tried everything that I can get my hands on to fix this...so now I am coming to you.

    Thanks for your time

  2. StephenNg
    Member
    Posted 5 years ago #

    Hi Jsandifer,

    Your host knows the server configuration and can help you better. I guess you need to set permission 777 to both of these folders for it to work

    - wp-content
    - uploads

  3. kmessinger
    Volunteer Moderator
    Posted 5 years ago #

    You can try this . . .
    1. Login to your admin page
    2. Go to settings
    3. Go to Miscellaneous
    4. Find Store uploads in this folder "/wp-content/uploads"
    5. If the / is there before wp-content just remove it.

  4. jsandifer
    Member
    Posted 5 years ago #

    @kmessinger Your brilliant! Thanks for the help guys...working now!

  5. elizabethrichardson
    Member
    Posted 5 years ago #

    Thank you so much - this worked for me too!

  6. erpay
    Member
    Posted 5 years ago #

    @kmessinger I've changed it like /wp-content/uploads but still there I take the same error that directory can't be created.

  7. wqamar
    Member
    Posted 5 years ago #

    Thanks my problem solved

  8. bernatagullo
    Member
    Posted 5 years ago #

    @kmessinger you are the one and only! thanks a lot

    this is a bug that somebody at wordpress should notice!

  9. taren9k3
    Member
    Posted 5 years ago #

    Just remove the / and you can upload everything you want.
    vlick.net

  10. Maximus Saint
    Member
    Posted 4 years ago #

    kmessinger, omg man you are a genius!!! thanks so much :)

  11. Kim Babbel
    Member
    Posted 4 years ago #

    @kmessinger, that was perfect...thanks a million :o)

  12. christodoulidesd
    Member
    Posted 4 years ago #

    Thank you so much! I am using wordpress through bluehost.com installation and that is what my exact problem was! Thanks!

  13. dancingotter
    Member
    Posted 4 years ago #

    This totally worked for me too, thanks so much!

  14. LSmith
    Member
    Posted 4 years ago #

    Praise Jesus H. this worked, thank you.

Topic Closed

This topic has been closed to new replies.

About this Topic