WordPress.org

Ready to get started?Download WordPress

Forums

Unable to create directory - Is its parent directory writable by the server? (85 posts)

  1. dorischua
    Member
    Posted 5 years ago #

    Hi, yesterday I got this HTTP error when trying to upload a photo. Then I realized all my blogs had the same problem. I contacted my webhost and they can upload just fine!

    I tried installing the plugin (image upload - HTTP error fix) but I'm still getting the same message: HTTP error. an error occurred during the upload. Pls try again later).

    I am trying to add the text in the htaccess as suggested by Pumpkin Slayer. But can anyone advise me - WHERE can I find the htaccess? I'm not good at these script stuff. Thanks!

  2. mbronsema
    Member
    Posted 5 years ago #

    I second blanketneworleans fix. It worked for me. I really do not like having WP-Content with full access. Anyway,

    I did this on IIS6, PHP5, and WP 2.6.

    Thanks blanketneworleans

  3. Kindaichi
    Member
    Posted 5 years ago #

    For my case, changing File Permissions of wp-content, NOT wp-content/uploads solves the problems.

  4. dancurranjr
    Member
    Posted 5 years ago #

    After reading everything - my fix was removing the /

    wp-content/uploads

    Not

    /wp-content/uploads

    Yep. Feckin WOW!~!!!!!!

  5. Unclebaby
    Member
    Posted 5 years ago #

    For me the solution was about the path.

    Looking at the 'Store uploads in this folder' path it was showing my full server file system path: /www/domainname.com/...

    Changing that to wp-content/uploads works fine.
    Also copying the content from a terminal path on the server fixes it and goes back to the short version: wp-content/uploads. This makes me think there was an error in there before but it's changed and working now so I can't say what it was or why.

  6. ganeshcp
    Member
    Posted 5 years ago #

    This is a very frustrating problem!

    I think it is a combination of permission and ownership thing.

    What worked for me: (not really a fix!)

    I manually created the follows directories: uploads/2008/08
    CHMOD them 777
    CHMOD wp-content to 777

    I manually made the directories, coz I got the error msg otherwise.

    Then on shell,
    CHOWN user:root /path/wp-content/
    CHOWN user:root /path/wp-content/uploads/

    This works on one of my blogs. The new images are created with user & group apache:apache. But it doesn't work on my other blog. On the other blog, the images get uploaded, but are broken. I can't access the images directly either! I don't know if that is a htaccess or ownership problem? Anyone help !

  7. Azeela
    Member
    Posted 5 years ago #

    Romik84 wrote:
    Go to General Settings and in WordPress address URL field leave: http://yoursite.com. This one is wrong: http://www.yoursite.com.
    Forget about CHMOD and SafeMode bullshits. It's a WP bug.

    Ok so how do I reverse this??? I figured I might try it out and now my f****** blog is totally messed up and I can't log in..

  8. Azeela
    Member
    Posted 5 years ago #

    Heeeelp!!! See post above.. I'm desperate! *cry*

  9. elithraldor
    Member
    Posted 5 years ago #

    This all just seems stupid....

    CHMOD files/folders to 777 - what about no?

    And guess what? its the only thing that seems to work. I can't do it 'cause of my provider. Fair IMO.

    So I tried everything else in this thread, but nothing is working.

    But what else is there to do?

    Last thing to do is just to use another blog-software! And go to McD or something..

    Just a little frustrated overhere.

  10. arminbw
    Member
    Posted 5 years ago #

    This problem isn't directly related to WordPress. Sometimes it's safe_mode, open_basedir or simply the fact that providers do not use CGI. It really depends on the configuration of the server. If it's done well, giving 777 permissions to user files isn't necessarily a huge security hole as your whole workspace might be protected quite well. If the set up is bad, you are screwed anyway.

    And yes, this is frustrating indeed. The Web 2.0 isn't actually a huge step forward in terms of security concepts.

  11. cstebner
    Member
    Posted 5 years ago #

    One such solution would be to assign the proper permissions to the parent wp-content directory. If you are using a default apache install, that user and group are both 'apache' simply chown apache.apache -R wp-content. When you next use the upload scripts, the webserver will be able to create the directories.. no reckless chmod'ing here, just proper permissions in the proper places.

    YMMV

  12. arminbw
    Member
    Posted 5 years ago #

    no reckless chmod'ing here, just proper permissions in the proper places.

    This only works if php save_mode is turned OFF.
    If it is turned off, what protects your directory from users on the server who are able to write php scripts?

    arminbw

  13. etorvinen
    Member
    Posted 5 years ago #

    Was having the same issue here http://eric.torvinen.net/blog/

    1. Login to your admin page
    2. Go to settings
    3. Go to Miscellaneous
    4. Find Store uploads in this folder
    5. Change it to wp-content/uploads

    I hope this helps everyone...

    this should fix the images... in my case i moved my wordpress install to another directory. This caused issues.

    You may also want to check the permissions of the uploads directory.
    which varies in different os/servers.

  14. Raddish
    Member
    Posted 5 years ago #

    Dancurranjr had it but I mis-read the post and didn't get the benefit of this simple fix until later via another forum (hours later!) I did Bluehost live chat twice and though they were willing to help me they were unable. They had me doing all the complicated things that have been suggested here but in the end it was so simple!
    1. Login to your admin page
    2. Go to settings
    3. Go to Miscellaneous
    4. Find Store uploads in this folder
    5. if it says "/wp-content/uploads" just remove the first forward slash so that it reads plain ol: wp-content/uploads

  15. Raddish
    Member
    Posted 5 years ago #

    p.s. I only had this problem on the 1st of the month, so I don't know if that means I will have to do that every month.

  16. golfunta
    Member
    Posted 5 years ago #

    Thanks so much. Taking the first forward slash off worked!! I am so happy.

  17. staypuftman
    Member
    Posted 5 years ago #

    I resolved this by playing with the upload paths in:
    General > Settings > Miscellaneous

    Simply deleting the existing path and pasting the FULL path of my image uploading folder fixed the issue for me. No CHMOD 777 crap - thats dangerous btw folks.

    peace out
    j

  18. patrickd88
    Member
    Posted 5 years ago #

    I also solved this problem by removing the single slash in front of wp-content/uploads as others mentioned. Worked great. Hope it works for you.

  19. JoshRoseman
    Member
    Posted 5 years ago #

    My solution was from Anonymous:

    I had a similar fix myself. I basically deleted the default path for the "Store uploads in this folder" field in "settings/miscellaneous" and put the full path in the "Full URL path to files (optional)" field.

    I also CHMODded /wp-content to 755 and /wp-content/uploads to 777. I selected "organize by month/year". It's working fine now.

    It's amazing how much little stuff can go wrong.

  20. cyriacgc
    Member
    Posted 5 years ago #

    I GOT IT WORKING, FINALLY !!!

    thanks to some guys who have posted here.
    i tried every method listed here, CHMOD, and changing blog address from http://www.domain.com to http//domain.com didnt help me

    what worked for me was, i changed store URL to wp-content/uploads it was something like home/bogee/...../wp-content/uploads after the upgrade to WP 2.7. i left Full URL path blank itself.

    thanks to every guy who have suggested this method

  21. Justin Tadlock
    Member
    Posted 5 years ago #

    This solution worked for me on WP 2.7:

    I am using WP 2.6. I CH'MOD (777) the following directories:

    wp-content
    uploads
    *every folder/subfolder with uploads

    I then went to Settings > Miscellaneous > Full URL path to files (optional)

    I put in: http://yourdomain.org/wordpress/wp-content/uploads

    and made sure my uploads were set to:

    wp-content/uploads

    Hope this helps!

    I think it was the setting of the file paths under Settings > Miscellaneous that fixed the issue.

  22. muaysteve
    Member
    Posted 5 years ago #

    I think it was the setting of the file paths under Settings > Miscellaneous that fixed the issue

    I just encountered this error today. I had just recently uploaded a new WP site from a local computer to a hosting account. When I uploaded the database, it retained the path from my local computer.

    So in my case it was the file path under settings/Misc

    Thanks for all the help on this thread.

  23. HellaBossKidd
    Member
    Posted 5 years ago #

    My solution:

    In the Miscellaneous settings I changed the Store uploads in this folder path to ../blog/wp-content/uploads as opposed to the default (/home/me/public_html/blog/...) That seemed to work fine.

  24. boy412
    Member
    Posted 5 years ago #

    ...and made sure my uploads were set to:

    wp-content/uploads

    I had migrated my blog from my development server to a hosted server recently. All was fine after hand-editing the SQL dump to reflect the new file paths...except this bit of info above! Once I reset the "Store uploads in this folder" to the default "wp-content/uploads" all was well.

    These issues surrounding file uploads are common. Unfortunately there are myriad causes for this. But I DID learn what I needed to know from this thread!

    Cheers...

  25. twop
    Member
    Posted 5 years ago #

    THIS FIXED MY PROBLEM:

    I was playing with some of the settings that weren't mentioned in any of the posts I found on the forums and was able to fix the problem WITHOUT messing with permissions and safe-mode. When logged into WordPress dashboard(wp-admin url page) I went to settings>miscellaneous. I changed 'Store uploads in this folder' to 'wp-content/uploads' (mine was this by default but I made sure it was this since I read it could cause this problem if it wasn't this), then I unchecked the 'Organize my uploads into month- and year-based folders' box. Unchecking this box and saving the changes is what solved my problem.

  26. melissasue
    Member
    Posted 5 years ago #

    Thank you, thank you, thank you! After three hours of working this issue (one of which was spent with my cranky internet connection) I can finally move on to what I was trying to do in the first place.

    *smooch*

    Thank you!

  27. agape731
    Member
    Posted 5 years ago #

    ARRRGGGG, I'm having same issue and twop's suggestion didn't work for me.

    Anyone?

  28. staypuftman
    Member
    Posted 5 years ago #

    Remove the first forward slash of your upload directory in the Settings > Miscellaneous section. Its works. Never do CHMOD 777. That is not an answer for a production website.

  29. joshreisner
    Member
    Posted 5 years ago #

    Hey, I was having this "unable to create folder" problem too. For me, it turned out that chmod didn't help. The issue was my upload_path in wp_options (for whatever reason) was wrong.

    I created a file called test.php and did a phpinfo() to determine what the correct DOCUMENT_ROOT was, then added that before the wp-content/uploads in the upload_path row of the wp_options table.

    This fixed it for me -- now even the Flash uploader works!

  30. huske
    Member
    Posted 5 years ago #

    Hey everyone,

    Here is a completely new twist to this problem. I am hosting my WordPress blog site on an IIS server running Windows XP with FastCGI and PHP 5.
    After setting up WordPress I exported my blogs from the wordpress.com web site and tried to import into my own WordPress. I kept getting this same mistake over and over again. The problem was that the upload_path in mySql database was pointing to the absolute path. I updated it to point to /wp-content/uploads.

    I guess it might not be of great help to most of you, but you might want to look at this option to try and solve the issue.

    Regards!

Topic Closed

This topic has been closed to new replies.

About this Topic