WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Unable to create directory. Is its parent directory writable by the server? HELP (14 posts)

  1. enlacosa
    Member
    Posted 2 years ago #

    I'm having a little difficulty with my wordpress media upload feature. Every time I try to upload an image, there's a message that reads:

    Unable to create directory.(Followed by a series of directories separated by forward slashes)Is its parent directory writable by the server?

    I've been looking around the internet, forums and similar topics and I still haven't found any resolution to this problem. I've already checked and unchecked the "Organize my uploads into month- and year-based folders" option and that hasn't worked for me. I've deleted the forward slash at the beginning of the directory in the "store uploads folder" option and also nothing. I've changed permissions in my FTP to various numbers as suggested in many forums but it has also failed me.

    I've spoken to a domain and hosting representative and he ran various tests and he gave me a little glimpse as to where the problem may be. He said that the issue that seems to be occurring is that WordPress hasn't created a folder within the wp-content/uploads folder where the images that I upload onto the site will be stored. I can't even figure out where the problem is! How would I go about resolving this problem? Please help! I'd really appreciate it!

    Thank you.

  2. Virtual Clover
    Member
    Posted 2 years ago #

    I don't promise this is the be all end all solution, just a couple of questions for clarification...but did you check the location path to see if the folder in question is where it's supposed to be? If it is there, then maybe it could be a permissions issue that is preventing the access to the folder itself. If the folder is not there, did you manually create the folder where it says it couldn't be created? If not, give that a try and see if it works.

    Unfortunately at this moment at 4am (insomnia and boredom, sue me) I don't recall specifically what the write permission code/number is, I *think* it's like 667 but don't quote me, someone else will surely know. I'm also too sleepy to google it ;-p But look around for the write permissions and open your ftp client, right lick the directory and change the permissions if it's not already set properly. And if it is, that's probably not the problem.

    I know it's not A1 help but something to try and eliminate if you haven't already. If nothing else, it can narrow things down more.

  3. esmi
    Theme Diva & Forum Moderator
    Posted 2 years ago #

    Try changing the permissions on the wp-content directory to 766. If you still have problems, try 767, 775 or 777. Once your uploads are working, change the permissions on wp-content back to 755 again and check that everything still works OK.
    http://codex.wordpress.org/Changing_File_Permissions

  4. enlacosa
    Member
    Posted 2 years ago #

    Ok well I truly apprectiate your help "staceytaylor" as well as you "esmi" but I still remain with the problem unfortunately :(

    @ staceytaylor: I tried the permission code you wrote "667" but it did not work. I also googled permission codes and such but none have worked. I've tried creating a folder within my "wp-content/uploads" directory but it doesn't let me for some reason. I use Filezilla as FTP and I get this error on the top left corner that reads:

    "Response: 550 Can't create directory: File too large.

    Now something that I came across last night while I was roaming around my FTP, now that you ask me to check the location path was that I found the folder which contains the same directory path as the one that appears in the WordPress media upload error message.
    The folder named "home" has the following directory path:

    home/content/07/7748007/html/wp-content/uploads/2012/01

    This folder is located in the same menu as the wp-content when in reality I think it should be in the wp-content/uploads folder together with all the images on my site. What's strange is the way there's two completely wp-content folders; the main one which contains all my website images and the other which is within the home folder.

    @ esmi: I tried all the permissions you wrote down but still nothing. When I set the permissions though I didn't check the option below nor did I select the sub-options that read:

    ✓Recurse into sub-directories
    •Apply to all files and directories
    •Apply to files only
    •Apply to directories only

    Do I have to check one of these options or no because I tried one of these options once and it took forever?

    Again I appreciate your help! :P

  5. esmi
    Theme Diva & Forum Moderator
    Posted 2 years ago #

    I've tried creating a folder within my "wp-content/uploads" directory

    That won't work. WordPress must create the uploads folder(s) itself. Have you tried asking your hosts for assistance?

  6. enlacosa
    Member
    Posted 2 years ago #

    I did speak to a domain and hosting represenative yesterday that was quite helpful but couldn't really expand much considering they don't really provide much help on website builders and such. He told me the exact thing your telling me now about WordPress creating an upload folder itself but for some reason it didn't. I thought that maybe if I manually created it, it would be the same thing but it didn't work. The represenative told me that for some strange reason WordPress has the directory in front of it's face but it can't get there. He said that there must be a 2012 folder inside my wp-content/uploads. What's really strange is that theres a 2012 folder inside this directory "home/content/07/7748007/html/wp-content/uploads/2012/01" as I explained to staceytaylor in the previous response. Do you think that might have something to do with the problem?

  7. esmi
    Theme Diva & Forum Moderator
    Posted 2 years ago #

    Possibly. Have you tried deleting both it & the uploads folder that you created?

  8. enlacosa
    Member
    Posted 2 years ago #

    I haven't tried deleting the directory: "home/content/07/7748007/html/wp-content/uploads/2012/01" because I didn't know if it was important or something but all of the folders in this directory path are completely empty. Maybe If I delete it, it'll try creating the folder in the right location? Should I delete it?

  9. esmi
    Theme Diva & Forum Moderator
    Posted 2 years ago #

    If all of the sub-folders are empty, you can safely delete the uploads folder.

  10. enlacosa
    Member
    Posted 2 years ago #

    Alright I deleted the entire home folder that contained that directory path but when I try to upload it still reads:

    Unable to create directory /home/content/07/7748007/html/wp-content/uploads//2012/01. Is its parent directory writable by the server?

    I already deleted that whole path though. Something to take in consideration though are the settings in my media option in the WordPress Dashboard. Don't know if that might be something that has to do with it.

    In the store uploads in this folder it reads: wp-content/uploads/
    and the "Organize my uploads into month- and year-based folders" is checked.

  11. esmi
    Theme Diva & Forum Moderator
    Posted 2 years ago #

    Remove the path from the "store uploads in this folder" field and leave it blank.

  12. enlacosa
    Member
    Posted 2 years ago #

    Ok I removed the path like you asked and tried uploading an image and the error still continues. I don't know why it keeps on asking about that directory though, if I already deleted the whole folder.

    Unable to create directory /home/content/07/7748007/html/wp-content/uploads//2012/01. Is its parent directory writable by the server?

  13. esmi
    Theme Diva & Forum Moderator
    Posted 2 years ago #

    Contact your hosts and ask them to investigate whether your wp-content folder has a folder permissions or ownership issue.

  14. enlacosa
    Member
    Posted 2 years ago #

    RESOLVED!

    Ok well I've spoken to my website hosts and luckily have helped me resolve my issue. It seemed that I had such a large amount of single files in the uploads folder that the wordpress uploader couldn't create a folder for the year 2012. The represenative suggested to delete as many old files as I can also considering the fact that the limit of files per folder is about 1000 files and the uploads folder had over 7000 single files. So it was virtually impossible for WordPress to create a 2012 folder. As soon as I eliminated some images the 2012 folder popped up and I was able to upload once again!

    Thanks anyway!

Topic Closed

This topic has been closed to new replies.

About this Topic