WordPress.org

Ready to get started?Download WordPress

Forums

Unable to create directory (21 posts)

  1. bwoolbright
    Member
    Posted 5 years ago #

    Hi,

    When I try to upload pics to my blog using the media uploader, this is the message I get, "Unable to create directory /home/content/b/w/o/bwoolbright/html/simply_mel/wp-content/uploads/2009/09. Is its parent directory writable by the server?" Has anyone ever had this problem and know how to fix it?

  2. Samuel B
    moderator
    Posted 5 years ago #

    wp-content/uploads/2009/09
    set chmod 777 on all of the above folders
    upload an image
    chmod folders back to 755
    should work from now on

  3. jackie
    Member
    Posted 4 years ago #

    I am having the same problem. I've set chmod to 777 and still no joy. What I have discovered is that when my WP 2.8.4 tries to create a new folder the user/owner or whatever you want to call it is apache. For all of the other folders I am the user. I deleted the "uploads" folder and all the sub folders (I had manually created subs). In Plesk I recreated the uploads folder and I am the user. Now when I try to upload a picture. WP creates the next folder - 2009 but it's user is apache and the next folder is not created. The error message is: "Unable to create directory /var/www/vhosts/mysite.com/httpdocs/blog/wp-content/uploads/2009/09. Is its parent directory writable by the server?"
    If I manually create the full path of folders and give them all chmod 777 then the message is "The uploaded file could not be moved to /var/www/vhosts/mysite.com/httpdocs/blog/wp-content/uploads/2009/09."
    Any ideas?

  4. rosbif
    Member
    Posted 4 years ago #

    I had this problem a while ago and started fiddling around with file permissions but it went away when I restored the default upload path statement in the upload settings (something like \uploads from memory - look for the note alongside the box). Good luck!

  5. AwengShah
    Member
    Posted 4 years ago #

    wp-content/uploads/2009/09
    I'm very new to wordpress can anyone show me step by step to upload image...have the same error

    how to use http://FTP..

  6. TRLocke
    Member
    Posted 4 years ago #

    Your solution is not working for me. I've set every level of the content directory to the 777 permission and nada so I changed them back. I don't even believe this is the first blog and image I've posted since the new WordPress version. It just suddenly stopped working today for some reason.

    I've seen this same solution repeated on a dozen sites. It doesn't make sense that this would suddenly stop working.

    Please help.

  7. TRLocke
    Member
    Posted 4 years ago #

    Okay, guys. This note from Nabeel is all I needed to fix this. I didn't need to change permissions (I spent over an hour trying all that stuff last night and changing them back for safety). Also didn't need to contact my host or anything. There was simply a slash in front of the directory in the default section under Settings, Miscellaneous. Removed the slash and the pictures posted. Thanks Nabeel. Here's the note from him to another user:

    hello tan,

    please make sure it is “wp-content/uploads” and not “/wp-content/uploads”

    waiting to know if it was still not solved.

    My default had the slash in front. Amazing. I didn't need to change permissions or anything.

    TRL

  8. jackie
    Member
    Posted 4 years ago #

    Well, mine doesn't have the first slash, ALL the folders are at 777, etc, etc (see my previous post). What is the problem? I did find a solution but it seems like a really bad idea. If (at my web host) I set PHP safe mode to off everything works. There should be a solution other than this. Hopefully there are now enough clues that the smarter ones can understand the problem and offer the correct solution. Please?

  9. Neville.2
    Member
    Posted 4 years ago #

    hmmm I am new to wordpress and it seems that there are many many posts (under various topics) but all with the same issue and it is still not resolved. I have followed at least 6 supposed solutions and I still have the problem with "Unable to create directory /home/virtual/site122/fst/var/www/html/blog/wp-content/uploads/2009/09. Is its parent directory writable by the server?"
    Anyone???

  10. esmi
    Forum Moderator
    Posted 4 years ago #

    Change the permissions on the wp-content directory to 766. If you still have problems, try 767 or 777. Once your uploads are working, change the permissions on wp-content back to 755 again and check that everything still works OK.
    http://codex.wordpress.org/Changing_File_Permissions

  11. Neville.2
    Member
    Posted 4 years ago #

    I have tried all that, still with the same result!

  12. Neville.2
    Member
    Posted 4 years ago #

    At last, I deleted the wp-admin and wp-includes files and reloaded them again (2nd time, the first time nothing had changed) but this time there was a / in front of the vp-content/uploads in Misc settings.
    I removed the / and hey presto!
    Both these were suggested as a fix but in seperate posts.

  13. jackie
    Member
    Posted 4 years ago #

    It is amazing to me that there are so many people with this problem. There is obviously a bug. I believe it has something to do with some of the web hosts setup. The only solution that worked for me is having the web hosting company set the PHP safe mode to off.

  14. carolewalsh
    Member
    Posted 4 years ago #

    I was having the same problem. The error message I get is: Unable to create directory /var/www/vhosts/carolewalsh.com/httpdocs/wp-content/uploads. Is its parent directory writable by the server?

    Maybe the problem has to do with the fact that I'm running on a virtual server. My wp files are in the http directory where all my other http files are. There is only one directory above the http directory. It includes:
    anon_ftp
    bin
    cgi-bin
    conf
    error_docs
    httpdocs
    httpsdocs
    pd
    private
    statistics
    subdomains
    web_users

    There is no way to get above that directory to anything resembling /var/www/vhosts/carolewalsh.com

    But anyway, the parent directory for wp-content is the httpdocs directory. So I tried to set the permissions to the httpdocs directory to 777 (it had been set at 700). It came up with an error, but it did it.

    I was then able to add images to my media library. So I set the permissions on the httpdocs directory down to 775, and I'm still able to add images to my media library. Yea!

  15. carolewalsh
    Member
    Posted 4 years ago #

    Oh, I forgot to mention... there was no "/upload" folder in the wp-content directory, so I manually created one. However, it still didn't work until I changed the permissions on the httpdocs directory.

  16. bbuxton
    Member
    Posted 4 years ago #

    If this is a persistent problem in a Plesk hosting environment, you've most likely left PHP Safe Mode enabled in the Web Host Settings for your domain.

  17. drakmarr
    Member
    Posted 4 years ago #

    I am having this issue as well only I know for a fact that my permissions are correct and whenever it tries to submit to directory it responds with:

    Unable to create directory W:\Domains\domainname.com\httpdocs\blog/wp-content/uploads/2010/03. Is its parent directory writable by the server?

    Also no upload folder for me so i created one as well I uploaded a file to it from ftp client just to see if it was detectable from media library and nothing.

  18. drakmarr
    Member
    Posted 4 years ago #

    I noticed that the url is weird some of it has \ and the second half has / like its looking on the local machine and then switches to web?

  19. hixsonb
    Member
    Posted 4 years ago #

    I too was experiencing this problem on a client's site but not my own. All the permissions were exactly the same.

    The solution that DID work for my client was what bbuxton mentioned. Thanks bbuxton!

    I just disabled "safe mode" on that domain for the client. He is hosted on Plesk. All of the other settings within the WordPress Admin Panel stayed at the defaults.

  20. Kevin Kwok
    Member
    Posted 4 years ago #

    This happened to me also, when i went to wp-content, the upload folder was not even there. I created one. then tried to upload a image via my blog again and still same error so i change chmod settings on uploada folder to 777 and it fixed it.

  21. marknaylor24
    Member
    Posted 4 years ago #

    Had a good browse around and couldn't find an answer either - Working locally on a mac.

    Seems a lot of the posts are about uploading to a web server, where as my error was locally on my mac. Changing permissions on the wp-content folder (choose the folder and 'get info' on it, permissions settings are at the bottom) to read and write on all sorted it out for me

Topic Closed

This topic has been closed to new replies.

About this Topic