WordPress.org

Ready to get started?Download WordPress

Forums

unable to connect to the database (7 posts)

  1. biswajit20
    Member
    Posted 2 years ago #

    iam using wamp server . and making database in mysql using phpMyadmin.

    after extracting wordpress , iam having problems in making the wp-config.php file

    it says

    can't select database

    please help me out

  2. Tara
    Member
    Posted 2 years ago #

    - double check your wp-config.php file settings for the database name, database username and database password. This is where most errors occur.

    -Then check that you don't need to change the database host from "localhost" to something else.

    -Check you have actually created a database with the same database name as is in your wp-config.php file.

    There are also many threads on this topic on these forums: http://wordpress.org/search/Error+establishing+a+database+connection?forums=1

  3. biswajit20
    Member
    Posted 2 years ago #

    @t-p

    i checked the settings several times

    the db name is: photography
    username is : admin
    password : //blank
    db host : localhost

    still its giving error..

    help me out

  4. Tara
    Member
    Posted 2 years ago #

    see if info in these threads can help

  5. michael.mariart
    Member
    Posted 2 years ago #

    From the sound of it, the most likely problem is that you have the database set up, and the user set up, but the user doesn't have any access permissions set on that database. In phpMyAdmin you can check what permissions each user has, so I'd suggest having a look in there even just to double-check the settings.

  6. RichardWPG
    Member
    Posted 2 years ago #

    - double check your wp-config.php file settings for the database name, database username and database password. This is where most errors occur.

    - Then check that you don't need to change the database host from "localhost" to something else. You can get that info from your hosting provider.

    - Check you have actually created a database with the same database name as is in your wp-config.php file.

  7. fastvision-technical
    Member
    Posted 2 years ago #

    In the config file look at hostname.

    If it still "localhost" try changing this to the IP address of the database server.

Topic Closed

This topic has been closed to new replies.

About this Topic