WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
Unable to communicate with CloudFlare API:.. (Warning from W3TC Dashboard) (3 posts)

  1. petrich
    Member
    Posted 1 year ago #

    Hello there,

    I am running WordPress 3.5.1 on a Windows Server 2008 R2 Standard Edition Service Pack 1) i586
    Web Server: Microsoft-IIS/7.5
    PHP Version: 5.4.12

    I just configured a CloudFlare free plan yesterday on this domain name 'keepintouchwithus.com'.

    Everything went OK until I tried to configure CloudFlare on W3TC dashboard...

    Now I constantly receive a warning in W3TC dashboard (Last Version: 0.9.2.8) that say the following:
    'Unable to communicate with CloudFlare API: Setting: zone_settings SSL certificate problem: unable to get local issuer certificate'.

    I cannot figure out what I am doing bad.

    Am I the first one to inform about this ?
    Have you heard of this before ?
    Can you guess the origin of this warning ?

    Thanks in advance for your help,

    Loïc

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. petrich
    Member
    Posted 1 year ago #

    Hi folks, I upgraded W3TC to 0.9.2.9 bu nothing has changed. am wondering if t has something related to my web server IIS not being configured correctly.

    I am having full control of the web server.

    So if someone thinks it might be related to some config on Web server, I am waiting for suggestions.

    Otherwise, if someone else is facing same issue, I would be glad to challenge this with him / her.

    Thank you

  3. Daniel
    Member
    Posted 1 year ago #

    I got the same issue to, just installed w3 total change and made the configuration on my 2003 server.

    Unable to communicate with CloudFlare API: Setting: zone_settings SSL certificate problem: unable to get local issuer certificate.

    But I do not thins this have anything to do with WordPress. It's Cloudflare that have an issue with their ssl certificate, maybe it has expired or something. Hence the "unable to get local issuer" comment. The server cannot validate if its authentic or not and closes the connection i guess..

    You need to contact Cloudflare support and ask them to fix their faulty ssl certificate..

    I will do the same too and ask them to update the certificate.. :-)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic