WordPress.org

Ready to get started?Download WordPress

Forums

Unable to auto update plugins or upload pictures (4 posts)

  1. kp2575
    Member
    Posted 5 years ago #

    I am installing wordpress (which I have done numerous times) for the first time on media temple hosting for a client who has a dedicated server

    After I completed the install I ftp'd all the plugins in and started creating content for them. One of the issues I have is that the images won't upload I get an error stating

    Unable to create directory /var/www/vhosts/vikkiziegler.com/httpdocs/wp-content/uploads/2008/09. Is its parent directory writable by the server?

    I checked the hosting and all the folders are writable.

    When I go to update the plugins I also have to use the ftp setup as opposed to just the autoupdate. I double checked the files and they are all writable.

    Everything in the .htaccess file is okay...

    Just wondering if there is something obvious that I am not checking that could be causing this?

  2. adnymarc
    Member
    Posted 5 years ago #

    I am having the exact same issue. Any idea's? I have already applied chmod -R 755 to the entire domain directory.

  3. omgitztrey
    Member
    Posted 5 years ago #

    @kp2575
    I had the same issues too when I first started with the dv... it was a kick in the ass to setup properly.

    Where are you finding these permission settings? ie: FTP, Plesk?

    @adnymarc
    Setting your entire directory to 755 is still slightly a security risk.

    For basic permission setup try following what I did.
    http://wordpress.org/support/topic/199164

    I'm still trying to figure out how to get the autoupdate for the plugins to work.

  4. fansoftech
    Member
    Posted 4 years ago #

    Just moved to MediaTemple myself and I'm experiencing the exact same issue with WP 2.7. Did you guys find an alternate solution other than changing dir permissions?

Topic Closed

This topic has been closed to new replies.

About this Topic