WordPress.org

Ready to get started?Download WordPress

Forums

Unable to add a new site (10 posts)

  1. pajo01
    Member
    Posted 4 years ago #

    I'm trying to add site using from Superadmin menu in WP 3.0 RC.
    Everything seems to work fine during the creation (no errors)
    But when trying to use or edit the newly created site i get 404.

    The main pages/site works.
    but not the subsites we trying to create.

    The installation is on our own Linux Redhat 2.6.18-194.3.1.el5

    I can see that the site apperes in the database table wp_blogs

    .htacces is updated
    _____________________________

    RewriteEngine On
    RewriteBase /wordpress/
    RewriteRule ^index\.php$ - [L]

    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    # BEGIN WordPress

    # END WordPress

    wp-config.php is uppdated
    _____________________________________________
    define('WP_DEBUG', false);
    define( 'WP_ALLOW_MULTISITE', true );
    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', false );
    $base = '/wordpress/';
    define( 'DOMAIN_CURRENT_SITE', 'virux007' );
    define( 'PATH_CURRENT_SITE', '/wordpress/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );
    ______________________________________________

    Any idées. I have tryed everything (i think)

  2. mod_rewrite has to be enabled on the server and it allows needs access to actually read the htaccess file.

    make sure
    AllowOverride FileInfo Options
    is in the vhost entry for that web account.

    All blogs are virtual. In subfolder installs, the rewrite rules create them. If they aren't being found, that means the htaccess file isn't even being read.

  3. hano
    Member
    Posted 4 years ago #

    Hi Andrea (I'am an colleague to pajo01)
    Thanks for your reply. Saw earlier some reply from you in another thread somewhere (you are frequent) in this matter wich earlier made us edit the httpd.conf to be like:
    <Directory />
    Options FollowSymlinks
    AllowOverride Fileinfo Options
    Order deny,allow
    Deny from all
    </Directory>

    is that correct and corresponding to your reply regarding vhost?

    I also noticed in hhtp.conf that under Servername, the line says
    #Servername http://www.example.com:80
    Do you think it could be a solution if I remove the (#) and change it to my actual servername?
    Any tip is helpul.

  4. is that correct and corresponding to your reply regarding vhost?

    Yes.

    Do you think it could be a solution if I remove the (#) and change it to my actual servername?

    No. The # is to comment out that line. Servername is the Directive, and the address following is the server name. So, as written, that line isn;t being used.

  5. hano
    Member
    Posted 4 years ago #

    Ok, so is there anything else to try? Anyone?

  6. hano
    Member
    Posted 4 years ago #

    Some more info:
    I can enable multisite and edit and visit the mainsite
    I can add and visit pages if I set permalinks to "default". If I choose some of the other options, I get 404.

    I can add sites, but are not able to edit or visit them (gets 404)

    I just commented out every line in .htaccess and got exactly the same behaviour described above (no differences)
    It seems like WP dont read .htaccess in this case?

    (I still have httpd.conf like:
    <Directory />
    Options FollowSymlinks
    AllowOverride Fileinfo Options
    Order deny,allow
    Deny from all
    </Directory>

  7. hano
    Member
    Posted 4 years ago #

    Ok, this is resolved now.
    What we did was two things in httpd.conf (not sure wich one actually solved it)

    1. Changed
    <Directory />
    Options FollowSymlinks
    AllowOverride Fileinfo Options
    Order deny,allow
    Deny from all
    </Directory>

    to

    <Directory />
    Options FollowSymlinks
    AllowOverride All
    Order deny,allow
    Deny from all
    </Directory>

    2 Changed
    # AllowOverride controls what directives may be placed in .htaccess files.
    # It can be "All", "None", or any combination of the keywords:
    # Options FileInfo AuthConfig Limit
    #
    # AllowOverride None to
    AllowOverride All

    Thanks Andrea for getting us on the right track!

  8. benek71
    Member
    Posted 3 years ago #

    Hm, it could be also answer for my problem with .htaccess ( I have simmilar situation) however I don't know where to find httpd.conf in my server to put AllowOverrideAll. Httpd.conf is a file, o a cataloge?

    Thanks for your help

  9. httpd.conf is an Apache file. If you're on a shared host, you do not have access to it. you'll have to contact your webhost's support team.

  10. JT Moree
    Member
    Posted 3 years ago #

    I have searched all day for the solution to this problem. I only found this post after figuring it out myself. I am putting some more keywords into this post so that others may be able to find it easier. Most people are hosting the site on a 3rd party server. My site is self hosted.

    I have a fresh install of WordPress 3.1 with multisite (multi-site, network, etc.) on Redhat 5. My wordpress is configured as a separate site in an Apache virtual host. There are no plugins installed in wordpress. I have never done anything with permalinks. Every new site I create shows a 404 error.

    [RESOLVED] The mod_rewrite engine needs some specific options set for the virtual host directory in order to work. Adjust the following for your site and put inside the Virtual Host configuration:
    <Directory /var/www/vhosts/wordpress>
    AllowOverride Fileinfo Options
    </Directory>

Topic Closed

This topic has been closed to new replies.

About this Topic