WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] unable to activate multisite (17 posts)

  1. crienoloog
    Member
    Posted 2 years ago #

    Hi all...
    I followed instructions with adding line to wp-config... clean install into root but can't get it to work. I don't see the extra link in the toolbox.
    Asked my hosting company; hostnet.nl if they have issues with it, and the answer was 'not'... it should work.
    I am sure I am missing something because it is not working.
    My host co. tells me I have to load websites into: webspace/httpdocs/
    this same 'webspace' directory has other directories; certs, cgi-bin, conf, error-docs, pd, siteapps, webapps, webstat, webstatssl and the file .htaccess, and of course httpdocs, in which I uploaded the clean install WP...
    Should I perhaps load the WP in the 'webspace' directory instead of the httpdocs directory?

    Thanks, for your help.

  2. crienoloog
    Member
    Posted 2 years ago #

    OK I thought, I just try to upload one directory up but that is not allowed.. so there has to be something else...

  3. Axel13
    Member
    Posted 2 years ago #

    Do you have a file called .htaccess in your root? When installing multisite you need to make changes to this file too... If you don't have it, you can create one with a text editor.

    http://codex.wordpress.org/Using_Permalinks#Creating_and_editing_.28.htaccess.29

  4. crienoloog
    Member
    Posted 2 years ago #

    Hi Axel...
    the .htaccess file is one directory up [see first post] so it is not in the directory where the WP is installed, which is in 'httpdocs'.
    The .htaccess file is one directory up.
    Besides, I can't change the rights or content, can't download the .htaccess. So I guess that is bad...
    Can I make a new one and put that in the directory where the WP install is?
    Will it conflict with the one that is one directory up?
    Ps, I have in C-Panel a button that says 'sync htaccess'... what can I do with that?

    Thanks for your help.

  5. Uh... Your host is smoking something.

    .htaccess has to be in the httpdocs folder.

  6. crienoloog
    Member
    Posted 2 years ago #

    Hi Ipstenu... yes I read that too...
    But since I can't download the original one in the directory above, I am not sure what else then the WP code I have to put in it...
    Or better said ; what is in the other one...
    And I understand I can put one in my directory where also WP resides and then Sync it with the one higher up, I don't know if I delete stuff in it. Or is Syncing also merging together?

    Thanks

  7. You can go into example.com/wp-admin/network/setup.php

    That doesn't need .htaccess to work and it stores the .htaccess and all there.

    And I understand I can put one in my directory where also WP resides and then Sync it with the one higher up, I don't know if I delete stuff in it. Or is Syncing also merging together?

    Not... with Multisite, no. Or rather, maybe, but your host is WEIRD o.O

    I would think you'd install it all to webspace/httpdocs/ personally.

  8. crienoloog
    Member
    Posted 2 years ago #

    OK I went to the link /wp-admin/network/setup.php and I got:

    Multisite support is not enabled.

    but like I did when I installed WP, I did put the wp multisite true in the config.php...
    Yes I installed the whole 3.3.1 version WP in webspace/httpdocs/ personally by FTP.
    thanks for your help and patience...

  9. Okay, is the wp-config.php that's IN webspace/httpdocs/ got that define in it? It should only have the ONE line right now.

  10. crienoloog
    Member
    Posted 2 years ago #

    Yes that is correct...

  11. And what error do you get on your domain?

    I mean, you can get into domain.com right? And domain.com/wp-admin?

  12. crienoloog
    Member
    Posted 2 years ago #

    domain - no error
    domain wp-admin - no error , but I don't see the extra network link under toolbox
    domain /wp-admin/network/setup.php - error; Multisite support is not enabled.

  13. Open up wp-config.php look for this:

    define('WP_ALLOW_MULTISITE',true);

    WHERE is it added? What lines are above and below it?

  14. crienoloog
    Member
    Posted 2 years ago #

    define('WP_DEBUG', false);
    /** Allow Multisite **/  
    
    define(’WP_ALLOW_MULTISITE’, true);
    /* That's all, stop editing! Happy blogging. */
  15. crienoloog
    Member
    Posted 2 years ago #

    Good morning Ipstenu,
    I had a message from my ISP that I had to make a .htaccess file and then sync it in C-panel.
    So I made a file and included:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    and synced the file as told. Re-uploaded the site, but no changes...
    I still can't see the extra function in the toolbox to build a network. So Multisite is still not activated.
    Which was confirmed by the error: /wp-admin/network/setup.php - error; Multisite support is not enabled.
    I even deleted the message in wp-config.php /** Allow Multisite **/
    although I know is just a comment.

  16. I can see what's wrong.

    define(’WP_ALLOW_MULTISITE’, true);

    Look VERY CAREFULLY at the quotes there. See anythign hinky? I do.

    Make it this:

    define('WP_ALLOW_MULTISITE', true);

    You have CURLY quotes. Unix doesn't like that.

  17. crienoloog
    Member
    Posted 2 years ago #

    WOW...
    You have no idea how happy I am it is something so simple and stupid...
    I have looked and apparently overlooked. And since I use a simple text editor in Ubuntu, I can't imagine how that happened.

    Thank you so much for your help.
    I changed the config file and now I can see the multisite function 'network'

    Have a great day! Mine now is... ;-)

    Eric
    from Bonaire, Caribbean Netherlands

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags