WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] Unable to activate jetpack comments? (21 posts)

  1. Bugsformymasonjar
    Member
    Posted 1 year ago #

    When I click activate, I get the blue success banner at the top of the page saying it has been activated, but the widget still shows that comments have not been activated, and nothing changes on the blog itself.

    Help?

    http://wordpress.org/extend/plugins/jetpack/

  2. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Jetpack Comments relies on the comment_form() function being used to display the comment form. Unfortunately, some themes still hard code a comment form instead of using this function.

    If your theme hard codes the comment form, you or the theme author will need to replace it with comment_form() in order for Jetpack Comments to be displayed correctly.

    You can read more about this function here:
    http://codex.wordpress.org/Function_Reference/comment_form
    http://ottopress.com/2010/wordpress-3-0-theme-tip-the-comment-form/

  3. Bugsformymasonjar
    Member
    Posted 1 year ago #

    Ok.... I did that, and it still is giving me the same activated, with no changes message.

  4. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Could you post a link to your site, so I can have a look?

  5. Bugsformymasonjar
    Member
    Posted 1 year ago #

  6. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Thanks.

    Could you try to disable W3 Total Cache, or clear your site's cache?

    If that doesn't help, could you try to enable or disable other Jetpack modules, and let me know if you experience similar issues with other modules?

  7. Bugsformymasonjar
    Member
    Posted 1 year ago #

    I disabled W3 Total Cache, ran the update for jetpack that came out today, and tried it again- and same thing. The banner at the top says it is updated, the box still says "activate" and no changes.
    The only module I didn't have active was the image gallery, and I activated that one no problem.

  8. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Could you try disabling all other plugins, one at a time, to make sure that none of them conflicts with Jetpack Comments?

  9. Bugsformymasonjar
    Member
    Posted 1 year ago #

    Found it- The problem is the plug in "Spam Free WordPress". Do you know of a spam blocker that will work with Jetpack now that I have the comments sorted out.
    Thank you SO much for your help!

  10. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    You could try Akismet: it is compatible with Jetpack Comments:
    http://akismet.com/

  11. robinlbryce
    Member
    Posted 1 year ago #

    My site is getting an error when trying to post a comment.
    What is happening. My site is RobinBryce.com

    The error is:
    Error 403

    We're sorry, but we could not fulfill your request for /wp-comments-post.php?for=jetpack on this server.

    You do not have permission to access this server. Data may not be posted from offsite forms.

    Your technical support key is: b815-4da1-cd36-1abb

    You can use this key to fix this problem yourself.

  12. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    @robinlbryce Do you use any of the Anti-Spam / Captcha plugins mentioned here?
    http://jetpack.me/troubleshooting/known-issues/

    Could you also try to deactivate all plugins, one at a time, to check if one of them conflicts with Jetpack?

  13. robinlbryce
    Member
    Posted 1 year ago #

    I am using WP Super Cache, not WP3. Is that the same thing?

  14. robinlbryce
    Member
    Posted 1 year ago #

    And How would I turn off that "mini??" engine when I can't see that option in the WP Super Cache settings?

  15. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Other users have reported similar error messages when using the Better WP Security plugin, or the Bad Behaviour plugin. Do you use one of these 2 plugins?

    And How would I turn off that "mini??" engine when I can't see that option in the WP Super Cache settings?

    I am not sure what you mean by "mini" engine. Does this error message appear when trying to deactivate WP Super Cache?

  16. robinlbryce
    Member
    Posted 1 year ago #

    The link above suggested I turn off the engine in WP 3 Cache. See below:

    W3 Total Cache

    There are known issues with the Minify engine in W3 Total Cache and many other plugins, including Jetpack. For now, you will need to turn off the Minify engine in W3TC to get Jetpack fully functional.

    I don't use any of the items listed in that link's list.

    I deactivated the WP Super Cache and the commenting is still messed up giving the 403 message from above.

    The comment path of submission is different than before as well. After typing in the comment the comment box blanks out and "Submitting Comment" shows up in bold black lettering. That used to never happen when the comments were working right.

    I've tried deactivating more plugins one at a time and none have reversed the 403 effects.

    Any other suggestions?

  17. robinlbryce
    Member
    Posted 1 year ago #

    When I click the link within the 403 error I get this in the comment box:

    Technical Support

    You submitted a form to the site which originated from a different web site. This is not allowed. To resolve this issue, submit your data from a form on the same web site.

  18. robinlbryce
    Member
    Posted 1 year ago #

    This is the 403 error:

    Error 403

    We're sorry, but we could not fulfill your request for /wp-comments-post.php?for=jetpack on this server.

    You do not have permission to access this server. Data may not be posted from offsite forms.

    Your technical support key is: 4086-9ddc-cd36-1abb

    You can use this key to fix this problem yourself.

    The "fix this problem yourself" is the link I mentioned above.

  19. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    This kind of error may appear if you use the Bad Behaviour plugin on your site. Could you try to deactivate it, as well as any other Anti Spam / Catpcha plugins currently active on your site?

  20. robinlbryce
    Member
    Posted 1 year ago #

    Okay, Bad Behavior did it.

    Will Jetpack continue to use the same method of comment processing and presenting? Will I have to not ever use Bad Behavior?

    The presentation of Jetpack comments has changed.

    When i'm signed in as admin, It lists the name with the link (if provided) "at" (with no link) "Edit" (which is the link for me, the admin, to edit the comment. Why does it show "Edit."

    When I'm not, it lists name as before with link, "at" with a link that cycles back to the originating blog post. Seems like there's not much point and very useless change to jetpack comments.

    I would rather have the older version back since it made the comments seem more professional looking. And it didn't mess up with plugins that stop spam bots.

    Any ideas about fixing the appearance of Jetpack comments?

  21. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Will Jetpack continue to use the same method of comment processing and presenting?

    Yes, Jetpack will continue to use the same way to present and embed the Comment form.

    The presentation of Jetpack comments has changed.

    While Jetpack Comments allows you to insert a custom comment form into your theme, it doesn't affect the look of the comments themselves. This is managed by your theme, and Jetpack doesn't have any control over this.

    If you want to make changes to your comment list, you will have to edit your theme's comments.php file.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.