WordPress.org

Ready to get started?Download WordPress

Forums

ugh! installed everything, page not found (15 posts)

  1. dtclarinet
    Member
    Posted 9 years ago #

    I created the subdir. muse in my site glitteringstew, created the database, modified the config file, named the directory glitteringstew.com/muse, uploaded it (as a folder) to the muse subdir. and went to http://glitteringstew.com/muse/wp-admin/install.php
    and UGH, 404 Not Found. I'm gonna call my website notfound and let it be some minimilast art!

    please help! :{

  2. And, is there an "install.php" file inside the "wp-admin" folder inside the "muse" folder at glitteringstew.com?

  3. dtclarinet
    Member
    Posted 9 years ago #

    OK, chipping, chipping. sorry about this, really. Now the database login is not working , but at least a wp error page came up. YAY for anything at this point. Will check with my server to make sure all is well there, but in case you have a suggestion, here is the error message.
    This either means that the username and password information in your wp-config.php file is incorrect or we can't contact the database server at localhost.

    * Are you sure you have the correct username and password?
    * Are you sure that you have typed the correct hostname?
    * Are you sure that the database server is running?
    Thanks for any help.
    David

  4. This is all the information you need:

    This either means that the username and password information in your wp-config.php file is incorrect or we can't contact the database server at localhost.

    * Are you sure you have the correct username and password?
    * Are you sure that you have typed the correct hostname?
    * Are you sure that the database server is running?

    It's not WP's fault. What ever you put in wp-config.php is either wrong, or that database server just went offline.

  5. dtclarinet
    Member
    Posted 9 years ago #

    i checked the database name, the login name, the host name, all are as set, i tried localhose as host name, no luck. i checked all privelages for the user, no luck.

    i still get the error listed above. Any suggestions?

    thank you,
    David

  6. Jinsan
    Member
    Posted 9 years ago #

    username and the database name would be:

    accountname_databasename
    accountname_username

    Are you sure you haven't just filled the fields with the username/password and database without the accountname?

    It sounds like the db settings aren't correct, or your files are not in the right location. The whoel thing is case sensitive so be sure to be accourate.

    You can also try dtopping the db and recreating it. you shouldn't have to touch localhost settings, it should be as is for 99% of users.

  7. Jinsan
    Member
    Posted 9 years ago #

    // ** MySQL settings ** //
    define('DB_NAME', Goatlover_mywordpress'); // The name of the database
    define('DB_USER', 'Goatlover_mywordpress'); // Your MySQL username
    define('DB_PASSWORD', '1luv4goats'); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value

    So it should be something like that. Make sure that you edited the congig-sample.php file and saved it as config.php (or whatever the file name is, but without the sample bit).

    IT shoudl be fairly straightforward

  8. dtclarinet
    Member
    Posted 9 years ago #

    I did everything as mentioned above.

    By the way, I installed in a subdirectory. I ended up uploading the contents of the directory, because uploading the "renamed" directory itself, whether named "muse" or "glitteringstew.com/muse" didn't work.

    Since my database name is dhthoma_glitteringstew_muse, how do I set wp to find "muse" rather than wordpress? I think this may be the problem. I added this paragraph after writing all below, but I'll lieave the info there incase something may be useful.

    the database info is entered as this
    define('DB_NAME', 'dhthoma_glitteringstew_muse'); // The name of the database
    define('DB_USER', 'dhthoma_clarinet'); // Your MySQL username
    define('DB_PASSWORD', 'mochi484493'); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value

    the values which the database are set to are:

    Host Name mysql3.hostexcellence.com (64.17.184.3)
    Port number 3306
    Database name dhthoma_glitteringstew_muse Click to remove
    phpMyAdmin Built in phpMyAdmin control panel
    you will need a properly configured dba user to log in (just add user with dba role if you don't have one)
    Quota Used 0.0 MB out of 1000 MB Change quota
    Database users dhthoma_clarinet Edit user's privileges Change password Click to delete
    dhthoma_garnet Edit user's privileges Change password Click to delete

    I'm able to login to the database manually with this information.

    I tried setting the host name to "mysql3.hostexcellence" but the same error page came up as with "localhost"

    The database is working. i chatted with an administrator at HostExcellence.

    In the database settings I set all permissions allowed to make sure there wasn't any limitation.

    The MySQL version is 4.o.20. PHP version 4.3.4

    What else can I try?
    Thanks for any help.
    David

  9. dtclarinet
    Member
    Posted 9 years ago #

    The install file cannot locate the config file. But wp-config.php is listed. It's not inside the admin folder, but that's the way it came with the download.

    David

  10. jpettit
    Member
    Posted 9 years ago #

    what if you try using the IP address of the database rather than localhost or the dns name? i had to use the IP to get mine to connect properly...

  11. dtclarinet
    Member
    Posted 9 years ago #

    I tried that and got a weird error code, but I give it another shot.

    Also, I looked at the install file and it said it couldn't locate the config file, but it's there. it's not in the same folder, but in the same location it was originally, by itself.

  12. dtclarinet
    Member
    Posted 9 years ago #

    YAYYYYYYY, YES, I'M SHOUTING. IT WORKED!!!!

  13. jpettit
    Member
    Posted 9 years ago #

    Can you please post to confirm what you did to get it to work so that others may benefit from your experience. thx!

  14. alexhitchins
    Member
    Posted 9 years ago #

    I was having this very same issue, and using the IP of the machine worked for me. Before I tried localhost and the machine name but no, IP seems the only way.

  15. JacksonBoyle
    Member
    Posted 9 years ago #

    I was pretty much in the same situation as David, and solved it with a bit of tinkering. If you are having the same kind of diffs, here's what I did.

    (using Hostexcellence, btw - they're a great host, and this prob wasn't their fault!)

    When you edit the config.php file, you need to enter the IP address as Alex mentioned, and make sure it looks like this -
    <?php
    // ** MySQL settings ** //
    define('DB_NAME', 'JackieB_examplewordpress'); // The name of the database
    define('DB_USER', 'JackieB_exampleTonyS'); // Your MySQL username
    define('DB_PASSWORD', 'exampletop99banana'); // ...and password
    define('DB_HOST', '69.136.981.3'); // 99% chance you won't need to change this value

    You don't need http:// or www. or anything in front of the IP address. This was what caused my errors!!!

    Hope this helps out someone...

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.