WordPress.org

Ready to get started?Download WordPress

Forums

User Access Manager
Uam not Show Access Managerpanel in Products (12 posts)

  1. cannap
    Member
    Posted 1 year ago #

    User Access Manager not Showing in WooCommerce Products

    Hi, i have a problem i cant see the Access Controll Panel from UAM in a Product but in a Page is working.

    Screenshot form a Working Page: http://cl.ly/image/2p213f3E1M3L/Image%202013-07-16%20at%204.46.46%20PM.png

    Screen from Product Page:

    http://cl.ly/image/2H3j0X1b2p13/Image%202013-07-16%20at%204.47.52%20PM.png

    u see there is no “Access” option like the other screenshot
    thanx

    The Theme Author write:

    Do you mean that you installed this access plugin http://wordpress.org/plugins/user-access-manager/ and on Product posts you do not have the “Access” switch? That could be because that custom post does not have the hook UAM is using to access posts. Please see plugin’s documentation for that. Thank you.

    but cant find any doc from the plugin :/

    thx

    http://wordpress.org/extend/plugins/user-access-manager/

  2. cannap
    Member
    Posted 1 year ago #

    in other themes like Mysile for WooCommerce from WooThemes is working:/

  3. jasond5
    Member
    Posted 10 months ago #

    Suddenly, My "Access" window is not appearing on Product pages. It does on the regular pages though.

    Any idea where it went? I looked at Screen Options at the top and there is no "Access" option on the product pages.

    J

  4. cannap
    Member
    Posted 10 months ago #

    U can edit the plugin

    protected $_aPostableTypes = array(
            'post',
            'page',
            'attachment',
        );
    to
    protected $_aPostableTypes = array(
            'post',
            'page',
            'product', //or 'products' dont know
            'attachment',
        );

    in this file
    http://plugins.svn.wordpress.org/user-access-manager/tags/1.2.4.3/class/UamAccessHandler.class.php

    plugindir/class/UamAccessHandler.class.php

    but i think this is not the best way

  5. Eric McNiece
    Member
    Posted 8 months ago #

    cannap is right - custom post type support is a long-running feature request. We need to re-add our custom post type slugs to the said $_aPostableTypes array every time the plugin is updated, unfortunately.

    Alex: you seriously rock, this plugin is great! Do you have any plans to add custom post type support? Would it be helpful if somebody made a patch?

  6. GM_Alex
    Member
    Plugin Author

    Posted 8 months ago #

    Tested it right now and it should work. See the public function __construct(UserAccessManager $oUserAccessManager) at http://plugins.svn.wordpress.org/user-access-manager/tags/1.2.4.3/class/UamAccessHandler.class.php

    So it should work with custom post types. Maybe some one has an idea?

  7. GM_Alex
    Member
    Plugin Author

    Posted 8 months ago #

    Could somebody with the problem give some feedback? A patch would be also nice.

  8. Eric McNiece
    Member
    Posted 8 months ago #

    Thanks Alex, I missed that construct - how long has that been in there?

    Commenting out $this->_aPostableTypes[] = $oPostType->name; definitely removes the access widget from custom post types, so I can confirm that custom post types are supported in this regard. Beautiful!

    I would be interested in hearing from OP about whether they have upgraded their plugin yet.

  9. GM_Alex
    Member
    Plugin Author

    Posted 8 months ago #

    Can somebody give some feedback if it works with WooCommerce and the latest version of the UAM?

  10. SteveBrand
    Member
    Posted 5 months ago #

    Can anyone help me with this. Not sure if I understand what changes I should make to the plugin to get it to work with custom post types but I am trying to use this with a Woocommerce store and I cannot get the products to hide.

    Can you help me with exactly the code changes? Thanks.

  11. SteveBrand
    Member
    Posted 5 months ago #

    I will give feedback when I get it working :)

  12. SteveBrand
    Member
    Posted 5 months ago #

    My problem is this: I can now see and configure the ACCESS panel on the products but the proud is not hiding when I am not logged in. When I am not logged in at all, I can still see this product that I have selected an access group for.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.