WordPress.org

Ready to get started?Download WordPress

Forums

typepad blog to WP3.5.1: broken links (404 error) (5 posts)

  1. japandan
    Member
    Posted 1 year ago #

    A few days ago I tried to move my typepad blog to WordPress, hosted by JustHost.

    The blog URL is http://www.danieldolan.com

    I used the TypePad import tool and I read all of the forum posts related to typepad, but I can't get my blog links to work. The front page displays (with strange layout), but the typepad icon still appears in the URL bar at the top of the page which makes me suspect that the blog has not actually moved... There are two links from that front page, and both are giving me the following error message:

    Not Found
    The requested URL /blog_index.html was not found on this server.
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    From the Posts link in dashboard I can see that all of my posts have been loaded into WP, so I wonder if perhaps the html in the front page of my blog that used to work fine in typepad is now for some reason not right for WP. Here is the html on that front page (it probably is not elegant html, since I used the advanced template on typepad and did some of the html myself). The links that are broken in WP are "Bio" and "Blog" in the html below:

    <p>&nbsp;</p>
    <p>&nbsp;</p>
    <p>&nbsp;</p>
    <p style="text-align: left;">
    <br /><br /></p>
    <p style="text-align: center;"><a title="Bio" href="http://www.danieldolan.com/bio.html" target="_self"><span style="font-size: 20pt; background-color: #40a0ff; color: #ffffff;">&nbsp;Bio </span></a>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; <a title="Blog" href="http://www.danieldolan.com/blog_index.html" target="_self"><span style="font-size: 20pt; background-color: #40a0ff; color: #ffffff;"><span style="font-size: 10pt;">&nbsp; </span>Blog&nbsp; </span></a> </p>

    In the WP General Settings I have added http://www.danieldolan.com to both the WordPress Address and the Site Address. At JustHost I pointed the domain (danieldolan.com) away from typepad and to the JustHost servers.

    Now I am out of ideas. Greatly appreciate any guidance. I know about the tp2wp paid service for migrating typepad blogs to WP, but hope to avoid that if possible. Thanks.

  2. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    The nameservers do not seem to be set to JustHost - see:

    http://www.whois.com/whois/danieldolan.com

    But those changes can take up to 72 hours to fully propagate, so perhaps that's the problem?

  3. japandan
    Member
    Posted 1 year ago #

    Thanks for the idea WPyogi. I just re-named my name servers on godaddy to point to NS1.justhost.com and NS2.justhost.com, names I just found on the JustHost site.

    The name servers I had been using (NS1.PIPEDNS.COM and NS2.PIPEDNS.COM) were given to me when I opened my hosting account with JustHost in Jan. 2011, and a google search shows them associated with JustHost, but maybe they changed since 2011?

    I will wait for the nameserver change to take affect and check my blog again.

    Meanwhile, any thoughts from other forum members?

  4. japandan
    Member
    Posted 1 year ago #

    More on my original post at the top of this page:

    My blog move from TypePad to WP still is not working. If you go to http://www.danieldolan.com, you will see two links (bio and blog), both of which lead to 404 error messages. I am still waiting to see if perhaps the name server change I made yesterday for my domain will solve the problem (see post directly above).

    But another clue: In the WP dashboard I can see the contents (posts) from my TypePad blog in my list of posts. When I look at those posts everything looks fine (minus images, which I have not yet moved from Typepad into WP, but that can come later). My bio page, which is the critical link from my front page and all I really care about, is included as one of those posts. You can see the WP bio page here (notice that the TypePad logo still shows in the browser window, and the island image at the top of my danieldolan.com page is missing): http://www.danieldolan.com/2012/11/10/bio/

    Now click on "5" under Recent Posts, and it goes to a strangely formatted version of my TypePad blog front page. I checked the permalink url for the WP bio page, and copied it into the html for this WP front page. You will see that the Bio link now works on this WP page.

    So now I wonder what to make of all of this. What is preventing the http://www.danieldolan.com page Bio link from working?

  5. I used the TypePad import tool and I read all of the forum posts related to typepad

    Exactly what tool and directions did you use? Look at your page source; you're showing the Typepad site in an iframe in WordPpress that is hosted at Justhost.

Topic Closed

This topic has been closed to new replies.

About this Topic