WordPress.org

Ready to get started?Download WordPress

Forums

WP Editor
TypeError: editor.getScrollInfo is not a function (7 posts)

  1. Darkwing
    Member
    Posted 10 months ago #

    For months now, when saving posts, I always get the following error displayed in the console of Firebug:

    TypeError: editor.getScrollInfo is not a function
    (?)(e=Object { originalEvent=Event submit, type="submit", timeStamp=0, mehr...})posts-...r=1.2.2 (Zeile 199)
    hasData(e=Object { originalEvent=Event submit, type="submit", timeStamp=0, mehr...})load-s...ver=3.6 (Zeile 5)
    hasData(e=submit )load-s...ver=3.6 (Zeile 5)
    
    var scrollPosition = editor.getScrollInfo();

    When I deactivate WP Editor, this error doesn’t appear any more.
    Am I the only one encountering this?

    Is there anything you can do about this?

    Thanks!

    http://wordpress.org/plugins/wp-editor/

  2. benjaminprojas
    Member
    Plugin Author

    Posted 10 months ago #

    Darkwing,

    I have been able to duplicate this and will try to provide a fix in the next release of WP Editor.

  3. Darkwing
    Member
    Posted 10 months ago #

    Thank you!

  4. benjaminprojas
    Member
    Plugin Author

    Posted 8 months ago #

    Darkwing,

    This issue should have been resolved in WP Editor 1.2.2. Can you confirm?

  5. Darkwing
    Member
    Posted 8 months ago #

    Hi!

    Thanks for taking care, but: still the same story.
    I’m using v1.2.2 for a long time btw …

    Are you sure you rolled out a new version correctly?

  6. benjaminprojas
    Member
    Plugin Author

    Posted 8 months ago #

    Thanks for the response. Can you deactivate all other plugins and let me know if the issue persists? If not, can you reactivate the plugins one by one and see if the issue comes back at that point?

    Also trying this with your theme would help eliminate that issue.

  7. Darkwing
    Member
    Posted 8 months ago #

    Hi!

    I deactivated all plugins: no error.
    I activated just WP Editor: the error.

    I tried this with 3.6.1, 3.7 and 3.7.1: the error.

    I tried this meanwhile with Theme 2012, WooThemes’ Canvas and WooThemes’ Peddlar: alway the error.

    Ergo: not really related to a particular theme, WordPress version or any other plugin – it’s WP Editor.

    … well, it’s not a ciritcal malfunction as far as I can tell; but it’s just worrying for a dev getting an error displayed and not knowing why. ;)

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.