WordPress.org

Ready to get started?Download WordPress

Forums

Post Thumbnail Editor
TypeError: c.tmpl.complete is not a function (4 posts)

  1. Mike Castro Demaria
    Member
    Posted 1 year ago #

    I love this plugin, and many thanks.

    But I'm sad to deactivate it due to back-office issue on WP 3.4.2 and 3.5

    --- err on load custom page/post ---
    On cutom post generated by magic field 1.6, When I click on post changing date (or droping UI bloc, etc..) I have followings javascript error :

    TypeError: c.tmpl.complete is not a function
    error source line:
    ...k;g=1===this.length&&this[0].parentNode;s=n||{};if(g&&11===g.nodeType&&1===g.chi...

    .../wp-content/plugins/post-thumbnail-editor/js/pte.full.js?ver=1.0.7

    --- error on interact with the interface ------

    TypeError: c.tmpl.complete is not a function
    a(t=a#edit-post-type-switcher.hide-if-no-js #, n=

    ":radio, :checkbox, select, option"

    )load-s...ver=3.5 (ligne 2)
    a(e=

    ":radio, :checkbox, select, option"

    , t=jQuery(a#edit-post-type-switcher.hide-if-no-js #), n=

    undefined

    )load-s...ver=3.5 (ligne 2)
    a(e=

    ":radio, :checkbox, select, option"

    )load-s...ver=3.5 (ligne 2)
    (?)(a=Object { originalEvent=Event click, type=

    "click"

    , timeStamp=

    1180494506

    , more...})jquery...l/seq/1 (ligne 1)
    a(n=Object { originalEvent=Event click, type=

    "click"

    , timeStamp=

    1180494506

    , more...})load-s...ver=3.5 (ligne 2)
    a(e=click clientX=1086, clientY=100)load-s...ver=3.5 (ligne 2)
    error source line:
    [Stopper sur une erreur]

    ...eturn t?u.length:u?nt.error(e):L(e,a).slice(0)}function at(e,t,r){var i=t.dir,s=...

    6 times => *wp-admin/load-scripts.php?c=0&load[]=jquery,utils,farbtastic,jquery-ui-core,plupload,plupload-html5,plupload-flash,plupload-silverlight,plupload-html4,json2&ver=3.5

    1 time => */wp-content/plugins/magic-fields/js/jquery.validate.pack.js?ver=3.5/eval/seq/1

    ----------------

    The errors is not present on page/post, only on custom post.
    If I desactivate it, no more error, and I can well use the post date editor.

    It look like a bad interaction between your plugin, WP, and maybe MF 1.6 (last from the 13/01/07)

    Tell me if you need help, test account or any more information to helo you to debug it.

    Thanks for all,
    Mike

    http://wordpress.org/extend/plugins/post-thumbnail-editor/

  2. sewpafly
    Member
    Plugin Author

    Posted 1 year ago #

    Please enable debugging for PTE (Settings -> Post Thumbnail Editor) and then copy the output here. Can you give me the link for MF plugin? Is it a free plugin?

  3. Mike Castro Demaria
    Member
    Posted 1 year ago #

    Hello,
    Thanks fot you reply.
    This is the plugin link : http://wordpress.org/extend/plugins/magic-fields/

    About the debug : http://dpastey.appspot.com//Q54D/
    But in fact my proble occure without using pst thumbnail, I just activate it, and I can't have access to the UI possibilities like drag block, edit time, etc..

    I hope this help,
    mike

  4. sewpafly
    Member
    Plugin Author

    Posted 1 year ago #

    I haven't been able to duplicate with the Magic Fields plugin. What happens if you disable thickbox (Settings → Post Thumbnail Editor)?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic