WordPress.org

Ready to get started?Download WordPress

Forums

Syntax
[resolved] Type broken in Chrome after 3.9 upgrade (18 posts)

  1. bensontel2
    Member
    Posted 3 months ago #

    This problem only seems to be in chrome. IE and Firefox renders title text OK. http://christopherrichards.com/book-reviews/

  2. bensontel2
    Member
    Posted 3 months ago #

    I'm using a child theme, but the same type issue happens when I switch back to the native Syntax 1.01 theme and when I preview it. The site type looks somewhat better at 110% but this still seems a problem. I reinstalled Syntax but still no luck. I have two monitors so the same type ugliness happens on both. I have another site and it manifests the same problem.

  3. bensontel2
    Member
    Posted 3 months ago #

    This looks like some problem between Google Fonts and Chrome, but I don't know much. And it does seem to break up more or less when zooming. 100% zoom looks bad.

  4. bensontel2
    Member
    Posted 3 months ago #

    I checked the demo Syntax theme on another computer in Chrome and the same type problem is there, so this looks not to be specific to my website or my child theme but to the theme itself. I love this theme and don't want to have to change it. I'm probably not the only one with this issue.

  5. Hi there, I had a look at your site in Chrome 34.0.1847.116 on Mac/OS 10.9.2 at various zoom sizes and couldn't see any problems with the text - it looked crisp and clean to my eyes.

    What version of Chrome are you running?

    What OS and version?

    Would it be possible to upload a screenshot of what you're seeing to help in troubleshooting?

    Here's a guide on how to make a screenshot, if you're not sure: http://en.support.wordpress.com/make-a-screenshot/

    You can upload the screenshot - in a graphic format like JPG, PNG, or PDF - in your Media Library, and provide a link so I can see it, or upload it with a service like Droplr or Imgur.

    Syntax uses the Merriweather Google font - how does it look to you on their demo page?
    https://www.google.com/fonts/specimen/Merriweather

  6. I also found this thread:
    http://code.google.com/p/googlefontdirectory/issues/detail?id=240

    Do you have Merriweather installed on your computer? If so, could you try uninstalling it?

  7. If you're on a Windows machine, you might also want to try some of the tips here:

    http://lonesysadmin.net/2011/09/12/how-to-fix-google-chrome-font-rendering-issues/

  8. bensontel2
    Member
    Posted 3 months ago #

    Kathryn,

    Thank you so much. I'll tryout all of your suggestions as soon as I can get to it, late today or tomorrow. I'm using W7 and downloaded and did a new install of Chrome today. For some reason (happily) the text looks better now but as soon as I change the zoom (currently 110%) to 100% the headline type becomes ragged. It wasn't just the type I see, the menu icon was distorted, too. But not right now. Will upload screen shots.

  9. bensontel2
    Member
    Posted 3 months ago #

    Here is the screen shot. I'm comparing how it looks in FF and Chrome. Thanks for telling me about how to link to it.
    http://christopherrichards.com/?attachment_id=1011

    As mentioned above, the type rendering has improved (?), but as you can see from the screen shot, it doesn't look as good as is should. It still breaks up when zooming in Chrome.

    I don't have Merriweather installed. Thank you again. I looked at all your suggestions but none are applicable. I'm glad there is some improvement.

  10. Could you please try turning off all Chrome extensions/add-ons and restarting the browser?

    http://support.google.com/chrome/bin/answer.py?hl=en&answer=187443

    Scroll down to the section called "Temporarily disable extensions."

    If the font display improves, try reactivating your extensions one at a time until you find the culprit.

  11. bensontel2
    Member
    Posted 3 months ago #

    Thanks. Sadly, the type only looks good at 110% and above and breaks up at 100% and below. I turned off all extensions and rebooted because I have Google hangouts in the background and I wanted to make sure I got a clean no-extension start for Chrome.

  12. Thanks for the update.

    I'm not sure you answered this question I asked earlier:

    Syntax uses the Merriweather Google font - how does it look to you on their demo page?
    https://www.google.com/fonts/specimen/Merriweather

    I'm trying to narrow down whether the issue is something with this specific font.

  13. bensontel2
    Member
    Posted 3 months ago #

    Thanks for hanging in there. The sample page looks better but not perfect. The type looks good at 100% and even 90% but starts to look ragged at 75% zoom. FF renders it perfectly.

  14. It looks like a problem specific to Chrome/Win7 with that font. I'm looking at the Google page in Chrome on Windows 7 and several sizes of the Merriweather font look ragged.

    You may want to consider using a different font. You could use a Google fonts plugin to make it easy to try different ones. You'll probably first want to check the font display in Chrome in the Google Font directory to be sure it looks OK there.

  15. bensontel2
    Member
    Posted 3 months ago #


  16. bensontel2
    Member
    Posted 3 months ago #

    Found this:
    https://productforums.google.com/forum/#!topic/chrome/oXILHkVG75M

    So paging down to the solution, it looks like the theme could be modified to fix this issue, but I wouldn't want to try it myself. I don't know enough.

  17. You could try adding the custom CSS that someone in that thread suggested, and see if it works:

    body {
       text-shadow: 0px 0px 1px rgba(128,128,128,0.01);
    }

    An easy way to add custom CSS is to install the Jetpack plugin and activate the Custom CSS module. You'll then add your custom CSS in the new stylesheet editor that'll appear in your dashboard, under Appearance > Edit CSS.

    As alternatives, you could either install a standalone custom CSS plugin, or create a child theme.

    In order to help other people do you think we should mark this topic as resolved?

    Sure.

  18. bensontel2
    Member
    Posted 3 months ago #

    Thanks for the workaround.

Reply

You must log in to post.

About this Theme

About this Topic