WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Two WordPress installations, one domain name and host (12 posts)

  1. Clicknathan
    Member
    Posted 6 years ago #

    I have a WordPress installation in the root of my server. I wanted to create a folder in the root called "es" and install a second version of WP in that. But doing so results in the /es install showing posts from both databases (I have two separate DBs).

    Has anyone ever experienced this before or know a work-around?

  2. MichaelH
    Member
    Posted 6 years ago #

  3. Clicknathan
    Member
    Posted 6 years ago #

    Thanks Michael - I don't know how I wouldn't have been able to find that page in a search.

    My particular issue came down to simply enabling permalinks in /es installation.

  4. exiledesigns
    Member
    Posted 6 years ago #

    Hello,

    I'm having the same issue here.

    I've got one install on the root, and another one in a folder. Each install has its own database-

    It works with the default Permalink structure. But as soon as I try to customize the permalink structure, any permalink points on my root install (404 error, of course).

    Any hint on how to get those permalinks customized without breaking the whole thing, please?

    Thanks in advance.

  5. RosieMBanks
    Member
    Posted 6 years ago #

    You might get a quicker response if you open up a new thread and refer back to this one, as this one has been marked "Resolved" and the WP gurus won't be looking at it.

    I'd help, but if you're following the instructions in the article linked above, I can't.

  6. exiledesigns
    Member
    Posted 6 years ago #

    Hello Rosie,
    Thanks for your input.
    I was not sure wether to create a new post. I'll go ahead!

  7. moshu
    Member
    Posted 6 years ago #

    Do you have two separate.htaccess files for the two installs?
    The htaccess needs to be in the folder where WP is installed: in your case one in the root and one in the folder where the other WP is.

  8. exiledesigns
    Member
    Posted 6 years ago #

    Hello moshu, and thanks!

    I didn't have two .htaccess!

    Now, I've just copied my root .htaccess & updated one line (AuthName), and uploaded it into my new directory WP.

    But I'm not sure it's enough. It still doesn't work when I update the permalinks structure, sigh.

    (sorry for the duplicated posts!)

  9. moshu
    Member
    Posted 6 years ago #

    There should NOT be any "authorname" line in a WP htaccess.

    It should llok like something:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    the above one is the standrad for the WP in the root. Obviously, the one in the subfolder should have different path. Why don't you let WP to write it or... if it can NOT, it shows you exactly at the bottom of the permalinks setting page what code you need to put into your htaccess file!

  10. exiledesigns
    Member
    Posted 6 years ago #

    I have those exact WP lines in my .htaccess files - but I also did have several other lines (regarding my host, maybe).
    I've now removed anything not concerning WP from it!

    I don't have anything showing on the bottom of my permalinks setting page. Does that mean WP can write on it?

    Should I change this line manually?
    RewriteRule . /index.php [L]
    to something like
    RewriteRule . /myfolder/index.php [L]

  11. moshu
    Member
    Posted 6 years ago #

    Better:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /yourfolder/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /yourfolder/index.php [L]
    </IfModule>
  12. exiledesigns
    Member
    Posted 6 years ago #

    Cool! It worked like a charm!
    Many thanks Moshu! <3

Topic Closed

This topic has been closed to new replies.

About this Topic