WordPress.org

Ready to get started?Download WordPress

Forums

two upload image errors (2.5) (21 posts)

  1. jamble
    Member
    Posted 6 years ago #

    When using the add media image upload button/popup to add an image to a post I get the following errors:

    When I upload an image from my computer it shows the uploading bar no problem but I then get this message:

    Fatal error: Call to undefined function: wp_constrain_dimensions() in /home/8688/domains/welcomebrand.co.uk/html/wp-admin/includes/image.php on line 173

    On the gallery tab it shows (1) to indicate an image has perhaps been uploaded but when I view the gallery tab I get this error (and no images)

    Fatal error: Call to undefined function: image_downsize() in /home/8688/domains/welcomebrand.co.uk/html/wp-includes/post.php on line 2326

    Any thoughts appreciated.

    Thanks.

  2. Bjooti
    Member
    Posted 6 years ago #

    I am getting the exact same errors. Very frustrating.

  3. Bjooti
    Member
    Posted 6 years ago #

    A though, on the first error we are getting - why does it say: /wp-admin/includes/image.php? There is no directory called just "includes"? Nor can I find a file called "image.php" in the wp-includes directory? Or am I just being stupid now?

  4. Tann
    Member
    Posted 6 years ago #

    Hi,

    I've got exactly the same errors.

    This one when I'm in the Media Library manager :
    Fatal error: Call to undefined function: wp_get_attachment_image() in /homepages/32/d146650184/htdocs/wordpress/wp-includes/post-template.php on line 386

    This one in the Media Library tab in the pop-up :
    Fatal error: Call to undefined function: image_downsize() in /homepages/32/d146650184/htdocs/wordpress/wp-includes/post.php on line 2326

    This one when I try to upload something in the pop-up :
    Fatal error: Call to undefined function: wp_constrain_dimensions() in /homepages/32/d146650184/htdocs/wordpress/wp-admin/includes/image.php on line 173

  5. Bjooti
    Member
    Posted 6 years ago #

    I've been searching the board High and low, but can't find any solution that works for me. There has been ideas about adding lines to the htaccess file, but for me that only produces another type of error.

  6. Tann
    Member
    Posted 6 years ago #

    I forgot to mention that the files I tried to upload were successfully uploaded in the "uploads" directory...

  7. Mitheor
    Member
    Posted 6 years ago #

    Similar problem here ...

    Warning: is_dir() [function.is-dir]: open_basedir restriction in effect. File(/) is not within the allowed path(s): (/home/s03d7073:/usr/lib/php:/usr/local/lib/php:/tmp) in /home/s03d7073/public_html/blog/wp-includes/functions.php on line 1042

    Warning: file_exists() [function.file-exists]: open_basedir restriction in effect. File(/) is not within the allowed path(s): (/home/s03d7073:/usr/lib/php:/usr/local/lib/php:/tmp) in /home/s03d7073/public_html/blog/wp-includes/functions.php on line 1033

  8. Bjooti
    Member
    Posted 6 years ago #

    Tann> Same thing here, the files are in the directory, but still getting errors in WordPress.

  9. Bjooti
    Member
    Posted 6 years ago #

    Sorry for bumping this, but why is wordpress calling for image.php and a directory called "includes" when there are no file or directory by these names in the download of the latest version of WordPress?

  10. Tann
    Member
    Posted 6 years ago #

    Ahum. I fixed it.

    You have to replace all the root files in wordpress folder (except config.php). Not only wp-admin and wp-includes folders.

    It works for me now !

  11. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    Bjooti: But there is such a directory. It's the wp-admin/includes directory.

    Make sure you uploaded ALL the files.

  12. Bjooti
    Member
    Posted 6 years ago #

    Oh sweet lord - i completely forgot to upload the root files. So embarrassed now! Thank you for bearing with me. I still had to modify the htaccess file though to make the uploads work.

  13. Mitheor
    Member
    Posted 6 years ago #

    I have replaced all the root files but i doesn´t work >_<

    If i try to upload an image it says:

    Warning: is_dir() [function.is-dir]: open_basedir restriction in effect. File(/) is not within the allowed path(s): (/home/s03d7073:/usr/lib/php:/usr/local/lib/php:/tmp) in /home/s03d7073/public_html/blog/wp-includes/functions.php on line 1042

    Warning: file_exists() [function.file-exists]: open_basedir restriction in effect. File(/) is not within the allowed path(s): (/home/s03d7073:/usr/lib/php:/usr/local/lib/php:/tmp) in /home/s03d7073/public_html/blog/wp-includes/functions.php on line 1033

    Warning: is_dir() [function.is-dir]: open_basedir restriction in effect. File(/) is not within the allowed path(s): (/home/s03d7073:/usr/lib/php:/usr/local/lib/php:/tmp) in /home/s03d7073/public_html/blog/wp-includes/functions.php on line 1042

    Warning: file_exists() [function.file-exists]: open_basedir restriction in effect. File(/) is not within the allowed path(s): (/home/s03d7073:/usr/lib/php:/usr/local/lib/php:/tmp) in /home/s03d7073/public_html/blog/wp-includes/functions.php on line 1033

    Warning: is_dir() [function.is-dir]: open_basedir restriction in effect. File(/) is not within the allowed path(s): (/home/s03d7073:/usr/lib/php:/usr/local/lib/php:/tmp) in /home/s03d7073/public_html/blog/wp-includes/functions.php on line 1042

    After that "gallery" is still empty. Any idea? httaccess has been disabled ...

  14. JBF
    Member
    Posted 6 years ago #

    I replaced the files in the root WordPress directory (not the folders I had already replaced when I upgraded to WordPress 2.5) and it fixed the problem for me.

  15. jaynee
    Member
    Posted 6 years ago #

    YES! FINALLY! It fixed most of the problems for me too. I can now see the graphics and expand the "show" menu. That's a step forward!

    I still can't batch upload (I can only do one file at a time), but it's rare that I'm uploading more than 3-4 images anyway.

  16. jamble
    Member
    Posted 6 years ago #

    I've re-uploaded the root files and I still have the same error.

    Any thoughts?

  17. ilyushkin
    Member
    Posted 6 years ago #

    I've re-uploaded the root files and I still have the same error.

    I experience the very same problem. I've been experiencing this problem in WP 2.5 RC1, RC2, RC3 and now 2.5. Looks like noone will address this issue anytime soon, according to wordpress 2.5.1 milestone.

  18. shogunn
    Member
    Posted 6 years ago #

    I have also re-uploaded the root files but am still having the same problem:

    "Fatal error: Call to undefined function: wp_constrain_dimensions()..."

    Another problem I am having is there are no images in the admin login page. Could be related?

  19. shogunn
    Member
    Posted 6 years ago #

    Ok I resolved this problem

    1) I deleted all the root files (except wp-config.php and .htaccess)
    2) Completely deleted both wp-admin and wp-includes folders from my server.

    3) Re-uploaded above mentioned files to the server.

    Now I get no errors. Hope that helps.

  20. shogunn
    Member
    Posted 6 years ago #

    I forgot to mention that this solved BOTH my problems.

    a) The fatal error problem is gone.
    and
    b) The admin login page displays correctly now.

  21. ssonmez
    Member
    Posted 6 years ago #

Topic Closed

This topic has been closed to new replies.

About this Topic