WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Two multisite installs on sigle ip. Both domains point same wp installation. (7 posts)

  1. Marcos Ramos
    Member
    Posted 2 years ago #

    ERROR: Visiting ServTWO.net it gets redirected to:

    http://ServONE.es/wp-signup.php?new=ServTWO.net

    When ServTWO should be redirected to its own independent wpms install.

    I have been following wp instructions and documentation and i have found this forum post that contains what I was just trying to do:

    http://wordpress.org/support/topic/multiple-multisite-installs-on-single-ip?replies=28

    So i have edited my VirtualHosts in my apache2 server to have this configuration:

    #
    # ServONE.es (/etc/apache2/sites-available/MyWpVH)
    #

    <VirtualHost ServONE.es>
    ServerAdmin admin@mydomain.com
    ServerName http://www.ServONE.es
    ServerAlias ServONE.es
    ServerAlias *.ServONE.es

    RewriteEngine On
    RewriteOptions Inherit

    # Indexes + Directory Root.
    DirectoryIndex index.php
    DocumentRoot /home/ServONE/wordpress/

    # Logfiles
    ErrorLog /home/ServONE/logs/error.log

    <Directory />
    Options FollowSymLinks
    AllowOverride All
    </Directory>
    <Directory /home/ServONE/wordpress/>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride All
    Order allow,deny
    allow from all
    </Directory>

    </VirtualHost>

    #
    # ServTWO.net
    #

    <VirtualHost ServTWO.net>
    ServerAdmin admin@mydomain.com
    ServerName http://www.ServTWO.net
    ServerAlias ServTWO.net
    ServerAlias *.ServTWO.net

    RewriteEngine On
    RewriteOptions Inherit

    # Indexes + Directory Root.
    DirectoryIndex index.php
    DocumentRoot /home/ServTWO/wordpress/

    # Logfiles
    ErrorLog /home/ServTWO/logs/error.log

    <Directory />
    Options FollowSymLinks
    AllowOverride All
    </Directory>
    <Directory /home/ServTWO/wordpress/>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride All
    Order allow,deny
    allow from all
    </Directory>

    </VirtualHost>

    Could you please help me to notice what may be wrong?

    Thank you.

  2. Are you trying to map a domain to one of the sub sites?

  3. Marcos Ramos
    Member
    Posted 2 years ago #

    Yes sorry. I am using the plugin "WordPress MU Domain Mapping" to map a third domain and this is working properly.

    So I have three domains. The first one is the native wpms installation. The second one is for the new wpms installation, and the third is just a blog that its contained in the first native wpms installation and mapped with that plugin mentioned.

    So I got three cases:

    1- ServONE.es works properly.

    2- ServTWO.net gets redirected to: http://servone.es/wp-signup.php?new=ServTWO.net (As wp consider im trying to register a new blog)

    3- ServThree.com gets redirected to http://ServTrhee.ServONE.es and it works properly.

    In the plugin options I have just mapped servthree.com and servtwo.net is not mapped there as I dont want it to be inside the first wpms installation, its should have its own independent wpms installation.

    What i want is to install two different wpms in the same ip.

  4. 2- ServTWO.net gets redirected to: http://servone.es/wp-signup.php?new=ServTWO.net (As wp consider im trying to register a new blog)

    That means you mapped the domain wrong. I use multiple Multisites on the same server, with the same IP, and different domains (totally separated) and it works fine.

    VirtualHost looks correct, though.

  5. Marcos Ramos
    Member
    Posted 2 years ago #

    So how should i do that?

    Its about wpms configuration or its just a thing about the plugin?

    I tryed to deactivate the plugin and its still the same.

  6. Marcos Ramos
    Member
    Posted 2 years ago #

    Both domains are:

    * IN A

    May be i should use CNAME?

  7. Marcos Ramos
    Member
    Posted 2 years ago #

    Fixed.

    The clue was to set up VHOSTS as this:

    NameVirtualhost *:80

    <VirtualHost *:80>
    bla1 bla1 bla1
    </virtualhost>
    <VirtualHost *:80>
    bla2 bla2 bla2
    </virtualhost>

    Thank you for ur help anyway. :D*

Topic Closed

This topic has been closed to new replies.

About this Topic