Ready to get started?Download WordPress


Two Home Pages (7 posts)

  1. Anonymous
    Posted 6 years ago #

    I'm new to WP - just 10 days. I want a static Home page and a separate Blog page. The template Home page was the Blog page. I couldn't access it to make it static, so I created a new Home page (I call it Welcome) and a new Blog page. Now I have two Home (Welcome) pages, and I don't know how to delete one without the other going.

    I'm sure it's something to do with altering the template, but I don't know enough about WP to do that.

    I'm still loading pages, so the site is incomplete. Here's the URL.


  2. LanceHaverkamp
    Posted 5 years ago #

    Same problem here: New WP 2.7 installation on a hosted server, http://TopLineColorado.com, I have two home pages & I don't know why.

    It worls properly using "default" or "classic" themes that came with the installation, but every other theme I've tried has two home pages!

    I'm using a WP as CMS for mostly static pages. Home page is set to 'static', My root page is blank and the second "home" page (http://TopLineColorado.com/home/) which shouldn't show at all, has the all the text that should be on the main (top) page.

    Any idea what's going on here?


  3. LanceHaverkamp
    Posted 5 years ago #

    Found this work-around:

    Someone needs to tell template authors that that should not hard-code a "home" tab.


  4. jonisolis
    Posted 5 years ago #

    I too have two "Home" pages showing up. So it is the template causing this trouble? I will check out the link above.

  5. jaward
    Posted 5 years ago #

    Remove the list code from the header.php file (can be done through your ftp program or through the "editor" in your appearance dashboard).

    This link may help from the forum.


    Most templates (themes) have this hard coded into the template.

    If you don't know what the html for

  6. is go here:


    Hope this helps.

    [signature moderated Please read the Forum Rules]

  • LT72884
    Posted 5 years ago #

    i was able to do it with my WP page. My home page is a static page. It WAS under options in the top left of the page. You first create your homepage and then go under options and select it as the home page.. I dont know why its not there anymore. For some reason i cant seem to find it... sory. but i was able to do it in the past. i have never updated my WP so i dont know why it aint there.

  • LT72884
    Posted 5 years ago #

    Ok found it. settings then under reading you can select front page displays and select the static page you created..

  • Topic Closed

    This topic has been closed to new replies.

    About this Topic