WordPress.org

Ready to get started?Download WordPress

Forums

Two FIXES for 2.6 login problems (18 posts)

  1. dolemite
    Member
    Posted 5 years ago #

    After some testing and investigation I found a solution to the problem of not being able to login to the admin panel.

    This fix applies only if you have:

    1) Upgraded from a previous version to 2.6
    2) Your blog is in a sub directory of the root
    3) You are using the Admin SSL plugin

    The fixes are noted in the Bug report:

    http://trac.wordpress.org/ticket/7322

  2. aborisov
    Member
    Posted 5 years ago #

    I'm not using the Admin SSL plugin but I have this issue.

    How can I fix it?

  3. dolemite
    Member
    Posted 5 years ago #

    Take a look at #2 in the Bug report. Does your wp-config file only have one secret key?

  4. JohnL
    Member
    Posted 5 years ago #

    Under Safari, after updating to a new version, I cannot log in at wp-admin as admin or any other user. When I submit accurate credentials, WordPress returns me to the login window. If I obtain a new password (using lost password), I still can't log in. The problem is specific to only some installations of WordPress (TeachEffectively.com; spedpro.org). It does not appear with a different installation (SpecialEducationToday.com) running on the same server.

    The problem occurred on two different computers (both running OS X 10.5.4).

    However, I can log in under Firefox.

    When I log in under Opera, I get a security notice that reads as follows:
    "A path in a cookie does not match the page address.
    You might want to ask the site's Webmaster to set legal cookies."
    The cookie name and content appears to be "wordpress_[randomCharacters]=admin%7c[moreCharacters]; path=/wp-content/plugins"

    Removing comparable cookies from Safari's cookie list does not make it possible to log in. Removing all cookies associated with a site did not make it possible to log in.

    I do not have the admin-ssl-secure plugin

    Adding three secret pass phrases to the config file did nada for me.

  5. elements
    Member
    Posted 5 years ago #

    Hi guys..first i was getting the message below and now I cannot login at all even after erasing cookies and cache. No one has answered any of my posts. Please please help:

    Upgraded from WP last year version to 2.6 and get this:
    thelreport.net

    Just did automatic upgrade and lost my site..I get this message when trying to follow instructions of manually DELETING Wp Marquee and Gregarious and Tag Warrior plugins:

    Fatal error: Cannot redeclare is_tag() (previously declared in /home/thelrepo/public_html/wp-includes/query.php:103) in /home/thelrepo/public_html/wp-content/plugins/UltimateTagWarrior/ultimate-tag-warrior.php on line 2426

    Update: Now the site won't load..simply takes me to login but wont login..just refreshes

    :(

  6. Viv
    Member
    Posted 5 years ago #

    The safari problem can be worked around, first quit safari, use another browser to log in to the admin area, now try safari again, you may need to hold down the shift key to clear the page cache.

    This will work if you were seeing a corrupted redirect address in the browser address bar after trying to log in.

  7. llenar
    Member
    Posted 5 years ago #

    THANK YOU DOLEMITE!! This really helped me. I deleted the cookies relating to this website and all is well.

    All of my WordPress websites are subdirectories hosted by GoDaddy.

    Earlier today I updated one of 4 sites to 2.6 using the WordPress Automatic Upgrade plugin. I thought I had not followed the instructions properly at the very end. Fortunately, my friend and WordPress mentor told me to download 2.6, upzip it and reload wp-admin. That worked. AND I had to re-activate ALL of the plugins.

    Even after that armed with the wp-admin fix, I felt confident that I could update the other sites, however, I decided to take try it out on one other less active site. Good choice. I experienced the SAME issue and this time, the wp-admin fix DID NOT WORK.

    Which led me here. I can see I'm not the only one.

  8. Anonymous
    Unregistered
    Posted 5 years ago #

    I just upgraded to 2.6. I couldn't log in as admin nor any other users. The site still exists but apparently all usernames were not recognized.

    I am using IE 7 and Windows Vista. Our site is hosted by Yahoo Web Hosting.

  9. Samuel B
    moderator
    Posted 5 years ago #

    @elements
    Ultimate tag warrior is not compatible with 2.6. You need to delete or rename it.

  10. dansinch
    Member
    Posted 5 years ago #

    Deleting the cookies seems to have worked for me.

  11. grahambeale
    Member
    Posted 5 years ago #

    this bug really sucks...is there no official word on this issue?

  12. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    What "official" word are you looking for? There is no bug that we know of. All known instances of the problem are fixed by simply clearing your cookies.

    Now, I did see one case where clearing cookies really didn't work, but the person with the problem switched away from WordPress instead of allowing me to debug it. I suspect interference from a plugin in that case, but had no chance to find out.

  13. grymoire
    Member
    Posted 5 years ago #

    I had this problem today as well. Clearing cookies didn't help. Using a freshly installed browser (just for the truly paranoid) didn't help either. (Sorry, Otto42.) What cleared things up was temporarily deleting my installed plugins files -- and yes, these were turned off before upgrading. This allowed me to log in and upgrade. I then put the plugins files back, turned them on, and everything seems to be working fine.

    Just for reference, the plugins I temporarily deleted were:

    • WordPress.com Stats
    • WordPress Database Backup
    • Sphere Related Content
  14. patterntheory
    Member
    Posted 5 years ago #

    I tried grymoire technique and no luck.
    Also tried cookies/cache/backup files
    Still cant access admin.

  15. anywaste
    Member
    Posted 5 years ago #

    I have also been having this problem after upgrading to 2.6.3. I have deleted my cookies (many times), and have tried logging on in different browsers. I have disabled all my plugins and have added lines to my wp-config file for the new cookies as suggested, yet I am still unable to login. Any more thoughts?

  16. NotThePainter
    Member
    Posted 5 years ago #

    Well, I'll give my 2 cents here. I read all of the above and it seemed like there were many ways to do things. I have 4 blogs, hosted on bluehost, and I spent literally hours on the first one, trying to upgrade, but not being able to login.

    I so did not want to clear my cookies.

    So after following the directions on upgrading exactly, I then made one further change. When I went to do the upgrade.php part I created a new user on my Macintosh, logged in as that user, then went to Safari and did the upgrade.

    That way I could have a cookie-free environment.

    And yes, it all worked well. Thanks all!

  17. serialboxhpc
    Member
    Posted 5 years ago #

    @NotThePainter

    Thank you! You solved my problem. I had already upgraded at that point though so I couldnt create a new user before the upgrade.

    I so did not want to clear my cookies.

    So after following the directions on upgrading exactly, I then made one further change. When I went to do the upgrade.php part I created a new user on my Macintosh, logged in as that user, then went to Safari and did the upgrade.

    That way I could have a cookie-free environment.

    Following your example, since I use Firefox as my main browser, I simply opened up Internet Explorer and was able to log in right away. Not wanting to delete all my cookies in Firefox I just went to the Cookies config section under Options and deleted only the cookies for my own website and left the rest there.

    As soon as I removed the cookies for my own blog I was able to log in.

  18. grahambeale
    Member
    Posted 5 years ago #

    weirdly, I added the 'secret keys' to my config file and then everything ran smoothly. very odd indeed,

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.