WordPress.org

Ready to get started?Download WordPress

Forums

Twitter Tools not updating (77 posts)

  1. blynnerobson
    Member
    Posted 4 years ago #

    It seems that the problem may not be Twitter tools...the problem is with twitter...I have a client's account that I have been trying to make work. It was working just fine with Twitter tools...as are several other sites I manage...but then suddenly stopped working.

    I deactivated and installed several other twitter plugins...ALL to no avail. It seems that Twitter is not allowing the connection...

    So this is either a server issue or a twitter issue...

    If we take that information and move forward how do we fix the problem...???

  2. servsite
    Member
    Posted 4 years ago #

    It worked fine on my server an on several blogs and then just stopped. Must be related to update of some kind. Sounds like developer has no answers. Is there another plugin that does work?

    Thanks

  3. Val Lynn
    Member
    Posted 4 years ago #

    I am having the same issue. I'm confident if Alex is aware of this, he is working on answers.

  4. wpmubp
    Member
    Posted 4 years ago #

    I had the same problem, twitter timeline not being updated upon publishing new posts on wordpress. If anyone is having the trouble, try Simple Tweet plugin (written by Japanese, but English available) with oauth option.

    btw, anyone having this error lately installed/updated WPML plugin?

  5. gaplauche
    Member
    Posted 4 years ago #

    I'm having the same problem. Twitter Tools widget hasn't updated my tweets in a while. I even tried updating manually in the settings. I'm running WP 2.9.2 with the Thesis 1.6 theme.

  6. traypup
    Member
    Posted 4 years ago #

    Same issue here. My tweets aren't showing up on my WP blog and my blog posts titles don't go to twitter. I checked the settings and it gives me an error about rate limit exceeded and that clients can't make more than 150 requests a day. Here's a screen shot:
    http://skitch.com/traypup/n793a/picture-1.png

  7. MattP225
    Member
    Posted 4 years ago #

    I'm currently getting the same error as traypup, re: not able to make more than 150 requests per day. This is happening on two blogs w/ two different Twitter accounts, both using WP 2.9 and the latest TT release.

    I don't know enough about the Twitter API to make a guess about the cause.

    EDIT: Okay I've got more data now. One Twitter account (an older one) actually does work, meaning it passes the login test in TT. The other account (which is about 2 months old) still gets the "requires authentication" test (and I've done this multiple times for each, so it's not a fluke, password error, etc).

    I checked settings for both accounts, and there's nothing between them that would lock one out. So in summary, I have no idea.

  8. MattP225
    Member
    Posted 4 years ago #

    And now randomly, it works just fine.

    It has to be something on Twitter's end.

  9. esbjorn
    Member
    Posted 4 years ago #

    Solved, at least for me.

    I tried MattP225's suggestion, and logged in with a different, new Twitter account, and it worked.

    Then I realized that the new Twitter account had a shorter password than my old one... I changed the password on the old account - and tada - it worked again! Seems like the password can be max 12 chars, and with no hypens...

  10. rickydunlop
    Member
    Posted 4 years ago #

    I was having problems where my database was not being updated with tweets.
    The way I fixed this was to deactivate the plugin, delete it from the plugins folder, drop the wp_ak_twitter table from the database and delete all options that begin with aktt_ from the wp_options table.
    The last step was crucial to getting it to work.

    Hope this helps someone.

  11. Bodhipaksa
    Member
    Posted 4 years ago #

    I followed the instructions in your blog post to the letter, rickydunlop, but unfortunately I'm still not getting a digest. I've never had a problem with tweets being created from blog posts, though.

  12. Bodhipaksa
    Member
    Posted 4 years ago #

    I take it back, rickydunlop! I discovered that digests had been scheduled, but for some reason the time was off and they didn't get published at the time I'd expected. However I did discover that there's another plugin called Twitter Digest that worked straight off. Some people might prefer using that if they can't get Twitter Tools to behave.

  13. keith1764
    Member
    Posted 4 years ago #

    Here's a wonky idea. Does anyone have the skills to add a little code to this plugin so that a log of the last few actions is recorded with errors emphasized in red?

    Kind of like was done in the MaxBlogPress Ping Optimizer plugin.

  14. madphill
    Member
    Posted 3 years ago #

    I installed Twitter Tools and it successfully added Tweets from the past into the blog. Then, I went back and created a new category to suite it called "Tweets" (I couldn't create a category during initial set up, so I just used Uncategorized initially)

    Then, went and reset the tweets and it didn't edit the category.

    SO...I deleted all of the posts, emptied the trash. Deactivated the plugin...deleted the plugin...reinstalled the plugin.

    When I went into settings the 2nd time around my details were still there (for some reason), so I tried resetting the tweets again...nothing.

    Any ideas how this can be resolved?

  15. eploy
    Member
    Posted 3 years ago #

    I too have the same problem. What is the solution?

  16. eploy
    Member
    Posted 3 years ago #

    The problem is definitely on the Twitter end.
    Apparently Twitter has some type of new security filter that messes up WordPress attempts to reach Twitter.

    I tried the suggested solutions of changing my pass word and I even tried changing to a different Twitter account. This does not help.
    Twitter post from Word Press WAS NICE WHILE IT LASTED.

    Can anyone reach Twitter and ask them what's the story?

  17. ldexterldesign
    Member
    Posted 3 years ago #

    As title; same issue: Twitter Tools not updating.

    Client of mine got in touch this evening, and from viewing his website feed, it hasn't been updated in 2 weeks.

    Any update on this before I try another solution?

    Thanks,

Topic Closed

This topic has been closed to new replies.

About this Topic