WordPress.org

Ready to get started?Download WordPress

Forums

Twitter Tools
Twitter Tools not triggering scheduled event (15 minute tweet download) (8 posts)

  1. macharborguy
    Member
    Posted 1 year ago #

    Running version 3.0.3 of Twitter Tools and version 3.4.2 of WordPress. It downloads tweets fine if I force the download via the TT settings page, but it doesnt seem to be triggering the scheduled event "aktt_backfill_tweets" every 15 minutes like it should be.

    I understand that it isnt a cron job and only triggers when the page is loaded, but i have been working on my theme for the past hour and it didnt grab any test tweets i posted the hour before, and only did so when I forced it in Settings.

    I have not modified the plugin what so ever.

    http://wordpress.org/extend/plugins/twitter-tools/

  2. Jonathan D. Johnson (jondavidjohn)
    Member
    Posted 1 year ago #

    Anyone having this issue can assist us in debugging by installing/activating this plugin we've written to get some relevant information regarding your environment and the state of the social lock.

    https://gist.github.com/4127490

    Place this file in your plugins directory and activate it. Once it is active you simply log into the admin and then add social_debug=true as a query string parameter.

    Example

    http://yourdomain.com/wp-admin/index.php?social_debug=true

    Copy and Paste the resulting text here.

  3. NightCheese
    Member
    Posted 1 year ago #

    I am having the exact same issue as macharborguy, but the site using the plug-in is part of a networked wordpress set up (multiple sites on one installation). Will your debug file work in a network set-up?

  4. Milan Dinić
    Member
    Posted 1 year ago #

    Although I don't know is this cause in other cases, I've found a bug that is preventing fetching of tweets in my case.

    Problem is that Twitter Tools doesn't have it's own cron job, and is instead relying on Social's cron job, which in turn doesn't run always but only when option to automatically fetch new comments is selected in Social. (see Social::check_system_cron() and Social_Controller_Settings::action_index())

    This means that if you have choose not to fetch comments (like I did, since I use Social only for Twitter Tools), tweets will never be automatically fetched.

    Solution is to have built in cron job for Twitter Tools that will run always when plugin is active.

  5. Alex King
    Member
    Plugin Author

    Posted 1 year ago #

    Hmm, I think the solution is to decouple Social's comment fetching from it's CRON system. The thread-safe CRON system is decidedly non-trivial so I don't want to include it in two places if I don't need to. Thanks for looking into this.

  6. NightCheese
    Member
    Posted 1 year ago #

    Since we have comments disabled, and we aren't using social to broadcast blog posts, I just enabled social's auto fetching of new comments so that the tweets would update. Hopefully this will get fixed in a future update of Social!

  7. patton
    Member
    Posted 1 year ago #

    I have the same issue, it only works when I manually download tweets. And only a few, I tried today and it only fetched last 24.

    # Social Debug

    Current Time: 2012-12-20 21:25:27

    ## Software Versions

    MySQL: 5.1.65-cll
    WordPress: 3.5
    PHP: 5.3.19
    Social: 2.6
    WebServer: LiteSpeed

    ## Social options

    social_locked: 1
    social_unlocked: Doesn't Exist
    social_last_lock_time: 2012-12-20 21:15:54
    social_semaphore: 1

    What can I do to make it run automatically, like it used to work before it turned into a part of Social?

    thank you

  8. Alex King
    Member
    Plugin Author

    Posted 1 year ago #

    Try the latest version of Social, make sure that CRON is enabled in Social.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic