WordPress.org

Ready to get started?Download WordPress

Forums

AddThis Social Sign In
[resolved] Twitter signin not working but all others are? (5 posts)

  1. GideonLupine
    Member
    Posted 9 months ago #

    When I try to login with twitter, it gives me the following error:

    --------------------------------------------------------------------

    Warning: Cannot modify header information - headers already sent by (output started at /home/public_html/wp-content/plugins/addthis-social-sign-in/includes/OAuth.php:897) in /home/public_html/wp-content/plugins/addthis-social-sign-in/addthis_social_sign_in.php on line 299
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/public_html/wp-content/plugins/addthis-social-sign-in/includes/OAuth.php:897) in /home/public_html/wp-content/plugins/addthis-social-sign-in/addthis_social_sign_in.php on line 302
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/public_html/wp-content/plugins/addthis-social-sign-in/includes/OAuth.php:897) in /home/public_html/wp-content/plugins/addthis-social-sign-in/addthis_social_sign_in.php on line 308

    http://wordpress.org/extend/plugins/addthis-social-sign-in/

  2. joivmaco
    Member
    Posted 9 months ago #

    I found the error in a plugin file: /wp-content/plugins/addthis-social-sign-in/includes/OAuth.php

    If you edit the code there is white space after the ?> closing tag at the end of the code. This fixed it for me and I was getting several errors.

  3. GideonLupine
    Member
    Posted 9 months ago #

    Why yes, it worked.

    There where blank lines after the ?> closing tag at the end of the code.

    Deleted them, and saved. Then it worked.

    Thanks.

    Has anyone else hit this issue?

  4. pinoybuilt
    Member
    Posted 8 months ago #

    Just installed. Facebook & Google logins worked smoothly.

    I fixed the Twitter error by deleting the white pace as mentioned above. Great find joivmaco. Thanks!

  5. wayneatcrossroadtechnologies
    Member
    Posted 6 months ago #

    Ditto on the "Great find joivmaco. Thanks!"

    UN-fortunately, I also ticked the check box for the Yahoo sign-in...

    Got this error message:

    Fatal error: Uncaught exception 'ErrorException' with message 'SSL: certificate subject name 'FG300B3908602133' does not match target host name 'me.yahoo.com'' in /web1/user/website/wp-content/plugins/addthis-social-sign-in/includes/openid.php:172 Stack trace:
    #0 /web1/user/website/wp-content/plugins/addthis-social-sign-in/includes/openid.php(261): LightOpenID->request_curl('https://me.yaho...', 'GET')

    #1 /web1/user/website/wp-content/plugins/addthis-social-sign-in/includes/openid.php(395): LightOpenID->request('https://me.yaho...')

    #2 /web1/user/website/wp-content/plugins/addthis-social-sign-in/includes/openid.php(559): LightOpenID->discover()

    #3 /web1/user/website/wp-content/plugins/addthis-social-sign-in/addthis_social_sign_in.php(406): LightOpenID->authUrl()

    #4 /web1/user/website/wp-content/plugins/addthis-social-sign-in/addthis_social_sign_in.php(217): addthis_ssi_yahoo('')

    #5 [internal function]: addthis_social_sign_in('addthis_social_...', Array)

    #6 /web1/user/website/wp-includes/ in /web1/user/website/wp-content/plugins/addthis-social-sign-in/includes/openid.php on line 172

    =-==-=-=-=--=
    line 172 says:
    if (curl_errno($curl)) {
    throw new ErrorException(curl_error($curl), curl_errno($curl));

    and line 42 says that:
    * The library requires PHP >= 5.1.2 with curl or http/https stream wrappers enabled..

    Some webhosting companies do not enable curl unless you ask them to.
    Obviously the case here.

    Don't see anywhere to enable http/https stream wrappers...

    So for now I "un" ticked the Yahoo authentication... Shame

    OH YEAH - the file

      /plugins/addthis-social-sign-in/includes/openid.php

    had NO closing ?> at the bottom of the file.

    Well, if I get some more time to look at this I'll update what I've learned :)

Reply

You must log in to post.

About this Plugin

About this Topic