WordPress.org

Ready to get started?Download WordPress

Forums

WordPress Social Login
Twitter Problem (10 posts)

  1. Ashwini Naik
    Member
    Posted 1 year ago #

    Hello All,

    Am using Network provider Facebook, Twitter, Google and LinkedIn. Except Twitter the other network providers are working fine.
    The problem with Twitter is I am able to connect twitter account and also authorize app. But once am done that and again if I click on Twitter it asks for authorize app.

    In simple words everytime if I'm logged in Twitter account and from my WordPress website if I click on Twitter icon , Twitter asks for "Authorize App". Am little confused whether this is plugin problem or Twitter problem. Please kindly help me resolve this.

    The other network providers ask for authorization of app only once and are working fine.

    Any help much appreciated. Please help me!!!

    Thanks a lot in advance,

    Aishu

    http://wordpress.org/extend/plugins/wordpress-social-login/

  2. Jon Jennings
    Member
    Posted 1 year ago #

    I'm seeing that too - every time a user who authenticates with Twitter clicks on the Twitter icon to login, they're asked by Twitter to authorize the app again.

    I wonder if it's common to all people using this for Twitter & nobody else has noticed/reported. Or if there's something we're doing wrong.

    I'm running on WP 3.6b1 if that might make a difference.

  3. dambacher
    Member
    Posted 1 year ago #

    Same here.

    WP 3.5.1
    Newest Version of plugin

  4. jayweb
    Member
    Posted 1 year ago #

    same problem here
    3.5.1 bouncer off

  5. jayweb
    Member
    Posted 1 year ago #

    hey my problem was fixed. I had to check the read/write box and not the read/write/access direct box in twitter app settings and made sure that the "Allow this application to be used to Sign in with Twitter" box checked as well.

  6. Jon Jennings
    Member
    Posted 1 year ago #

    Wow - confirmed here!

    I've now checked the "allow this application to be used to sign in with twitter" box (seems kinda obvious in hindsight!) and Twitter logins work for me as they should.

    I currently HAVEN'T got the "read and write" radio button checked, just the "read only" button - but I've turned several settings on and then off again so this doesn't provide categorical proof of exactly how the settings should be, although it does seem like login shouldn't really need write access to your twitter account.

    Either way, looks like Twitter authentication does work. Thanks for your help jayweb

  7. RonStrilaeff
    Member
    Posted 1 year ago #

    Piggybacking ... when a user logs in using twitter, it get's stuck on the twitter page "Authorize <site> to use your account?" The big blue "Sign In" button appears to click but nothing happens.

    I have checked the Application Type: "Read and Write" radio button and the "Allow this application to be used to Sign in with Twitter" checkbox.

    What else could it be?

  8. edwardbarker
    Member
    Posted 1 year ago #

    I might as well jump in on this thread rather than starting a new one. Similar problem with Twitter. From the error logs:

    [Tue Jul 02 04:07:31 2013] [warn] [host www.unitedrant.co.uk] [client 81.152.8.101] WordPress database error Unknown column 'user_wsl_email' in 'field list' for query SELECT user_wsl_email as data_field FROM<code>wp_users</code> where ID = '3251' made by require_once('wp-admin/admin.php'), do_action('settings_page_wordpress-social-login'), call_user_func_array, wsl_admin_init, include('/plugins/wordpress-social-login/includes/admin/components/users​/index.php'), wsl_component_users, wsl_component_users_list, wsl_get_user_data_by_user_id, referer: http://www.unitedrant.co.uk/wp-admin/options-general.php?page=wordpress-​social-login&wslp=bouncer

    Any thoughts?

  9. esmi
    Forum Moderator
    Posted 1 year ago #

    @edwardbarker: As per the Forum Welcome, please post your own topic. Posting in an existing topic prevents us from being able to track issues by topic. Added to which, your problem - despite any similarity in symptoms - is likely to be completely different.

  10. Damian
    Member
    Posted 1 year ago #

    If you are using twiter go with ftp to the plugin folder wordpress-social-login/hybridauth/Hybrid/Providers/ , open Twitter.php and change

    $this->api->api_base_url      = "https://api.twitter.com/1/";
    
    to
    
    $this->api->api_base_url      = "https://api.twitter.com/1.1/";

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.