WordPress.org

Ready to get started?Download WordPress

Forums

[closed] Twitter oEmbed language (13 posts)

  1. docflo
    Member
    Posted 2 years ago #

    The language of my oEmbedded Tweets seems to be stuck on German. How can I change this? wp_config has define('WPLANG', ''); and everything else is in English. There is no German language file present.

  2. Can't reproduce this one. Have you done the usual plugin dance?

  3. Andrew Nacin
    Lead Developer
    Posted 2 years ago #

    We're not passing a language header at all to Twitter's oEmbed. Perhaps they are detecting something from the HTTP request?

  4. inzaghi89
    Member
    Posted 2 years ago #

    Same here. My server is located in Germany and Twitter oEmbed lang is set to 'de'. As we have checked in other locations there is same situation. Twitter oEmbed use 'server based' location as default lang.

  5. joeventures
    Member
    Posted 2 years ago #

    I've reproduced this on a test domain, but with an interesting twist. If I post a Twitter embed on a page, it works properly. But on a post, it is in French:

    Page: http://test.c4atlanta.info/?page_id=7

    Post: http://test.c4atlanta.info/?p=1

  6. phpdevelopment
    Member
    Posted 2 years ago #

    Same here my server’s location is German. When I checked in other location, it works properly. But on a post, it is in other language

  7. inzaghi89
    Member
    Posted 2 years ago #

    For me it works the same way on both pages and posts. This twitter widget should have some way to set the lang manually, or it should get this from wp-config.php, or just configure it in functions.php.

  8. stuartgbreckenridge
    Member
    Posted 2 years ago #

    I can reproduce this and have no idea how to fix it.

    You can see it on this post:

    http://www.stuarticus.com/2012/07/06/robbed-by-vodafone/

  9. blepharisma
    Member
    Posted 1 year ago #

    I have the same problem.

    Inexplicably, all twitter buttons are in French on posts.
    http://www.ayria.com/2012/07/covenant-august-2012/

  10. This is such a wild and rare problem, it's got to be something specific about your installs.

    This goes to the old standards: turn off all your plugins and switch to twenty eleven.

    Also make a new post in the regular trouble shooting section, since it's not a alphabeta problem anymore.

  11. inzaghi89
    Member
    Posted 1 year ago #

    I've tested this on fresh WP installation. This is not an error of old installation and/or some of plugins, themes... I've tested this without any external plugins and using latest default theme.

  12. cisoprogressivo
    Member
    Posted 1 year ago #

    My site is in italian, but it's located in germany. So all the tweets are in german.

  13. FWIW, 'something specific about your installs' also includes your servers. Check PHP versions and languages, etc etc. (cisoprogressive's post is, I think, what's happening here, by the way. Its not WP, it's Twitter being idiots.)

    And please make new topics, as this isn't an alpha/beta problem, and we've never been able to reproduce it.

    If you're having this, please make a topic with the following:
    PHP version and language
    server specs (Apache on CentOS etc etc)
    Any possibly relevant language related server settings
    WP version
    SQL version (and again, language)
    Can you reproduce this on other servers?
    Can you reproduce this on a localhost install?

    We need to collect the info in order to trace down what happens.

Topic Closed

This topic has been closed to new replies.

About this Topic