WordPress.org

Ready to get started?Download WordPress

Forums

DevBuddy Twitter Feed
[resolved] Twitter feed only updates when I click "Save Changes" (4 posts)

  1. wittyoctopus
    Member
    Posted 1 year ago #

    Thanks for this great and simple plug-in. It seems like it will do everything that I need it to do. However, I am having an issue. I have gone through the process of creating a Twitter Developer App and have input all of the appropriate information into the "Twitter Feed Settings" Section under "Settings" in the wordpress admin panel. However, the Twitter feed displayed on my webpage only updates when I click "Save Changes" in the "Twitter Feed Settings." Otherwise the Twitter feed that your plug-in displays remains static. I have a feeling this has something to do with the plug-in checking the Twitter servers for updates, or something along those lines. Any help would be appreciated. Thank you again for developing this plug-in.

    Oh, and if it makes any difference I am currently developing my website using a local host server program, MAMP, on my mac. Could that be impacting the plug-in's ability to check for updates?

    http://wordpress.org/plugins/devbuddy-twitter-feed/

  2. wittyoctopus
    Member
    Posted 1 year ago #

    An update. Apparently my website is getting the tweets, however, they are appearing about 35 minutes after they are posted. I have a feeling this is related to how often the plugin is communicating with the Twitter API, or something like that, is there any way to decrease the time between the posting of a tweet and it appearing on my site?

  3. EjiOsigwe
    Member
    Plugin Author

    Posted 1 year ago #

    Hi and thanks for using the plugin.

    Twitter allows (I believe) 350 requests every 15 minutes so if it's just you that's doing the checking it's unlikely you've hit that limit. From what I've gathered it appears that the issue is the plugin's caching facility. By default it caches the feed for an hour.

    Fortunately I've just released an update which offers the ability to change the time the feed is cached for or to not cache at all.

    • If you're using the settings page the option is just under the number of tweets you select.
    • If you're doing it via template tag you'll want to add 'cache_hours' => 0 as an array item.
    • If you're using the shortcode add cache_hours="0" as an attribute.

    0 hours disables the cache, basically.

    Update and give it a try, and be sure to come back and let us know if it's resolved your issue.

  4. EjiOsigwe
    Member
    Plugin Author

    Posted 11 months ago #

    Thread closed since there hasn't been a response in over 2 weeks.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic