WordPress.org

Ready to get started?Download WordPress

Forums

Twitter Widget Pro
[resolved] Twitter feed only updates if logged in or wp-super-cache deactivated (6 posts)

  1. perryb
    Member
    Posted 1 year ago #

    That's it really - I've tried changing settings in wp super cache but nothing seems to have any effect beyond switching it off.

    http://wordpress.org/extend/plugins/twitter-widget-pro/

  2. sgronjaer
    Member
    Posted 1 year ago #

    Hi, super chache does not empty its cache once a twitter feed is updated.

    you would have to set supercache so that it reguarlary re-loads your cache.

  3. Aaron D. Campbell
    Member
    Plugin Author

    Posted 1 year ago #

    In this case, your Twitter feed will update whenever Super cache does, so if you have it set to keep your page cached for a day then your feed will update once a day. If you have it set for a week, then it will update it once a week.

  4. webaware
    Member
    Posted 1 year ago #

    Old thread, but still a valid topic...

    I can see a few of ways to work this; am facing the problem myself right now.

    • disable caching of pages with twitter feeds -- which is fine for sites with twitter feeds only on selected pages, but no good on sites with twitter feeds everywhere
    • if TWP fired an action when it updated its transients, a site could hook that action and tell WP Super Cache to clear its cache (fine for high-volume sites with frequent page/post updates, horrible for lower volume sites with infrequent page/post updates)
    • TWP could have an AJAX load option, where the widget is updated via AJAX pull once the (cached) page has loaded (which means extra work for Mr. Campbell!)

    Aaron, that third option is obviously best, but it means work. Is it something you have planned? If not, are you amenable to accepting a code contribution if someone else implements it?

    cheers,
    Ross

  5. Jake Love
    Member
    Posted 1 year ago #

    I'm having the same issue with my Dynamic Sidebar function. I have the setting turned on in the admin and have added the following code:

    <!--mfunc dynamic_sidebar( 'sidebar-1' ) -->
    <?php dynamic_sidebar( 'sidebar-1' ); ?>
    <!--/mfunc-->

    It works when I first clear the cache but when I try and refresh the page again it breaks the layout.

    Suggestions on how to pull a dynamic sidebar in?

    Thanks,
    Jake

  6. Jake Love
    Member
    Posted 1 year ago #

    Found the solution to my issue! You have to check a few options under the settings page. Make sure to check the box for "Enable dynamic caching" and "Late init".

    That should do the trick!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic