WordPress.org

Ready to get started?Download WordPress

Forums

Twitter Embeds - what am I doing wrong? (26 posts)

  1. cellobella
    Member
    Posted 2 years ago #

    I found the status url for the twitter embeds I wanted.
    I put them in the html screen... they came up as text.
    I put them in the visual screen... they came up as text.

    How do I make them do the pretty twitter update that 3.4 promises?

  2. Felix Renicks
    Member
    Posted 2 years ago #

    Did you put the URL on its own line?

  3. cellobella
    Member
    Posted 2 years ago #

    Yes.

  4. Try wrapping them in [embed] like so.

    [embed]https://twitter.com/Cellobella/statuses/213966886076026882[/embed]

    See if that works.

  5. cellobella
    Member
    Posted 2 years ago #

    Now it comes up as a link.
    This is the page: http://redsultana.com/2012/06/16/the-closet-accountant/

  6. Now that's odd. Twitter embeds work on my test setup and regular install.

    It may be something's interfering.

    Try disabling all your plugins and switch to the Twenty Eleven theme. Then edit and save that post and see if using [embed]...[/embed] sorts it out.

    If it does fix it, switch back to your theme and try again. Then start with the plugins one at a time until it comes back.

  7. cellobella
    Member
    Posted 2 years ago #

    Sigh... still not working. Am now on Twenty Eleven theme with no plugins.

    Loving your ideas though. :)

  8. *Scratches head* Since that didn't work, try putting it back and installing this plugin.

    http://wordpress.org/extend/plugins/twitter-embed/

    Prior to 3.4, I used this to activate Twitter embeds but with 3.4 I no longer needed it. It didn't hurt having it (and I only removed it today) but see if that does it for you.

    When you activate the plugin edit the post and re-add the link to the Tweet. Save it and see if it works.

  9. cellobella
    Member
    Posted 2 years ago #

    Hey that worked! Thanks heaps! :)

  10. kerrmunications
    Member
    Posted 2 years ago #

    The embed wasn't working for me either, so I'll give that plugin a try.

  11. What's troubling me is that the Twitter embed ought to work with 3.4 and without that plugin.

    I was using that plugin and now I'm not. Twitter embeds still work for me, same on my test install too without that plugin.

    Tonight I'll look some more, I think there is something basic I'm missing.

  12. GhostStorm
    Member
    Posted 2 years ago #

    I can get it to work with embed, but thats no good if I have to do it everytime I want to quote twitter.

  13. kerrmunications
    Member
    Posted 2 years ago #

    I can't get it to work any of these ways:

    - pasting the URL (having upgraded to 3.4)
    - using [embed]...[/embed]
    - using the plugin mentioned

    I guess my theme (DICE by bringthepixel) must conflict somehow.

  14. I can get it to work with embed, but thats no good if I have to do it everytime I want to quote twitter.

    ...If Twitter embed works for you, isn't that the point of this thread to get that working...?

    @kerrmunications, try deactivating all of your plugins, switch to Twenty Eleven, and create a new post with a Tweet in it.

    If that works, then it's probably an issue with your theme or plugins. You can rule out the plugins by activating them one at a time until they're all back. If the Twitter embed still works, then re-activate your theme and see it it breaks.

    If it does break after all that, then it's your theme. ;)

    You can get support for your commercial theme at the vendor forum.

    http://bringthepixel.com/support/

  15. kerrmunications
    Member
    Posted 2 years ago #

    Thanks Jan. I shall give it a go.

  16. kerrmunications
    Member
    Posted 2 years ago #

    How bizarre. I deactivated all the plugins, switched to Twenty Eleven, created the post with the tweet, and ... it still didn't display!

  17. With that as it is, try the plugin.

    http://wordpress.org/extend/plugins/twitter-embed/

    Edit the post and try one last time...

  18. Kay Cam
    Member
    Posted 2 years ago #

    I can't get the embed to work either

  19. sharilynn1999
    Member
    Posted 2 years ago #

    @Jan - what do you recommend for youtube to show ebmedded within the posts. they show up (both twitter and youtube) on the index page but not within the posts when clicking through on that particular post (i mostly do magazine styles for my clients)

    thanks,
    Shari

  20. jonny5v
    Member
    Posted 2 years ago #

    They said it's suppose to work in Text Widgets. But it doesn't. Can anyone confirm this?

  21. padraigbeirne
    Member
    Posted 2 years ago #

    You shouldn't need an extra plugin to embed tweets in 3.4+
    Had the exact same problem and this resolved it for me...

    On your admin dashboard go to Settings > Media

    Under the 'Embeds' title make sure Auto-Embeds is ticked. Pasting twitter urls should now work just like pasting youtube, vimeo and flickr urls. More info here - http://codex.wordpress.org/Embeds

    Hope this works for you! :-)

  22. wonkotsane
    Member
    Posted 1 year ago #

    I've had this problem too - even had one embedded tweet out of 4 or 5 on a page not working! I switched theme and then switched back again and they've started working. Bizarre.

  23. NEO1980
    Member
    Posted 1 year ago #

    Is anyone still having trouble with this issue. I have not been able to resolve it with any of the methods listed.

    Is there any way to trouble shoot this further?

  24. alchymyth
    The Sweeper & Moderator
    Posted 1 year ago #

    @NEO1980

    per forum rules, please start your own topic,
    and add as much information there as possible.

  25. scoochymarc
    Member
    Posted 1 year ago #

    I've been suffering with this problem and managed to resolve it by removing the 's' and changing the link from https://... to http://...

  26. craft.ryan
    Member
    Posted 1 year ago #

    I figured something out that might be helpful. Make sure that when you paste the url link into the body of your editor, that you remove the actual link. So that its plain text and not a linked url.

    Doing that fixed it for me.

Topic Closed

This topic has been closed to new replies.

About this Topic