WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Facebook: Advanced Social Optimization
[resolved] Twitter button causes Pages to not display (10 posts)

  1. BlackLiteSpecial
    Member
    Posted 1 year ago #

    Hello!

    I'm having an issue after updating to 3.2.1 of Facebook OG. If I elect to have the Twitter button shown on the bottom of my pages all that will show up on the rendered page is the post/page title. If I uncheck the Twitter button, everything returns to normal.

    I'm running WP 3.5 with the Responsive theme (custom child theme). My website is at http://www.blacklitespecial.com/

    I apologize if this has already been resolved, I did many searches and couldn't find any reference to the problem. If you need any more information I'll do my best to supply it, I'm still pretty new to WordPress and troubleshooting it.

    Thanks in advance!

    ~Laken

    http://wordpress.org/extend/plugins/nextgen-facebook/

  2. JS Morisset
    Member
    Plugin Author

    Posted 1 year ago #

    Most javascript, including twitter, is loaded into the header. By default, the NGFB header code has an execution priority of 10. You could try to load it a little later and see if that makes a difference. Try to add the following to your wp-config.php:

    define('NGFB_HEAD_PRIORITY', 100);

    If that doesn't work, you could try adding the original twitter javascript code to your footer:

    <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>

    js.

  3. JS Morisset
    Member
    Plugin Author

    Posted 1 year ago #

    It's been a few days without feedback, so I will assume this is no longer an issue and mark the thread as resolved.

    Thanks,

    js.

  4. BlackLiteSpecial
    Member
    Posted 1 year ago #

    Sorry for not responding, due to unrelated computer issues I haven't had a chance to try the fix. I'll hopefully have it done here shortly! I appreciate the response!

  5. JS Morisset
    Member
    Plugin Author

    Posted 1 year ago #

    I've made some changes to the button javascript in the next version. Download the current dev version, and see if it fixes the problem. If it doesn't, then set the "JavaScript in" option for Twitter to 'Footer'.

    The dev version is available at: http://downloads.wordpress.org/plugin/nextgen-facebook.zip

    Thanks,

    js.

  6. BlackLiteSpecial
    Member
    Posted 1 year ago #

    OK, tried the latest version, changing the javascript option to "Footer", no change. Added the excecution priority line to the wp-config.php, no change. I didn't try adding the javascript to the footer because I'm honestly not quite sure where to put it. I'm assuming in the footer.php file?

    I updated WordPress before updating the plugin, and made all changes after all updates.

  7. JS Morisset
    Member
    Plugin Author

    Posted 1 year ago #

    Sounds like there's somekind of incompatibility between the Twitter javascript (from Twitter) and your theme... You'll have to do a little more digging to find out why the two don't work together.

    I guess first thing I'd try is to switch your theme to something else (like one of the stock WP themes) and see if the problem persists. If it does, then maybe its related to another plugin. Try disabling them one by one and see if the problem goes away.

    Let me know what you find. If there's anything I can do, let me know.

    I'll set the status to resolved since this issue isn't strictly an NGFB problem, it's a problem with the Twitter javascript, which is from Twitter itself.

    Thanks,

    js.

  8. BlackLiteSpecial
    Member
    Posted 1 year ago #

    I really appreciate the help! Sadly I'm still pretty new to this, and I know pretty much nothing about Java. Was able make a few interesting discoveries, though:

    Changed to the defaul 2012 theme, it was still broken. Put my original theme back.

    Started disabling plugins. Disabled SlideShow Gallery, still broken, but this time there's the following JavaScript error on the page along with the title:

    `Fatal error: Call to undefined function curl_init() in /var/www/blog/wp-content/plugins/nextgen-facebook/lib/googl.php on line 44'

    Disabled NextGen Gallery, no change.

    Disabled All-in-One Favicon, no change. Those are all the active plugins I have.

    When I re-enabled Slideshow Gallery, the error went away and it returned to showing the page title and nothing else.

    No idea if this helps any at all. Again, thanks for your help in this!

  9. JS Morisset
    Member
    Plugin Author

    Posted 1 year ago #

    Ah, got it. Your PHP doesn't have the curl module, so the link shortening method is failing. I've added a check for the curl_init() function in the new 3.4 version (just released). This should fix your problem. ;-)

    BTW, without the curl module, links cannot be shortened for Twitter, so you might want to look into that...

    js.

  10. BlackLiteSpecial
    Member
    Posted 1 year ago #

    Installed the PHP cURL plugin and that did it! Also upgraded the plugin again. Everything is back to normal!

    Again, thanks for all your help in this. I really appreciate it!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic