WordPress.org

Ready to get started?Download WordPress

Forums

WordPress Social Login
Twitter API Version 1.1 (11 posts)

  1. strangerstudios
    Member
    Posted 1 year ago #

    Twitter just retired their API v1. You must use version v1.1.

    Official Twitter message:
    ---
    The Twitter REST API v1 will soon stop functioning. Please migrate to API v1.1.
    https://dev.twitter.com/docs/api/1.1/overview
    ---

    I am not sure of the differences in the versions, but just changing the endpoint in (/wordpress-social-login/trunk/hybridauth/Hybrid/Providers/Twitter.php) fixed it on my site.

    Edit http://plugins.svn.wordpress.org/wordpress-social-login/trunk/hybridauth/Hybrid/Providers/Twitter.php
    - $this->api->api_base_url = "https://api.twitter.com/1/";
    + $this->api->api_base_url = "https://api.twitter.com/1.1/";

    Cheers!

    http://wordpress.org/extend/plugins/wordpress-social-login/

  2. polle001
    Member
    Posted 1 year ago #

    Thanks for sharing.

    Can someone confirm this fix is ok ?

    Any news about an update for the plugin ?

  3. polle001
    Member
    Posted 1 year ago #

    An Unespecified error #6 is appearing in my site when using social login. I did the fix mentioned above, but it seems it does not help.

    Anyone knows a fix ?

    Thanks.

  4. darrenmeehan
    Member
    Posted 1 year ago #

    I've been working with this plugin on a development site, and cant get confirm if any other changes are needed to support version 1.1 of Twitters API. It's a pity this plugin wasnt updated in time for the changes, as there was time to work on it.

  5. erichopf
    Member
    Posted 1 year ago #

    darrenmeehan, you're right. I can't believe the author didn't fix this in a timely manner. A great plugin from someone with a full-time job and other things on their plate, and who does the development free for the community. I mean, what is wrong with him? :p

  6. emielm
    Member
    Posted 1 year ago #

    @polle001:
    On my websites the twitter login was also not working and strangestudios' fix did work in combination with checking the "sign in with twitter" box in your twitter app settings. Hope this helps for you.

  7. polle001
    Member
    Posted 1 year ago #

    Thanks @emielm, actually it was unchecked there and now it seems its working. I am still having the problem with Google....

    Lets hope the author updates the plugin soon.

  8. eldenroot
    Member
    Posted 1 year ago #

    Please update this awesome plugin!

  9. eldenroot
    Member
    Posted 1 year ago #

    I have no problems with Google login! It works great, just set callback URL correctly

  10. darrenmeehan
    Member
    Posted 1 year ago #

    erichopf, I didn't mean anything like that. I've tested the plugin and though I've a lot of other edits it works fine with Twitter with the above change.

  11. Michael Ecklund
    Member
    Posted 1 year ago #

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.