WordPress.org

Ready to get started?Download WordPress

Forums

WP to Twitter
Twitter API now requires HTTPS (17 posts)

  1. Joe Dolson
    Member
    Plugin Author

    Posted 7 months ago #

    Hello!

    To head off what will undoubtedly be some support requests, I wanted to let you know about a change in the Twitter API as of January 14th, 2014.

    The Twitter API used to accept either HTTP or HTTPS connections for posting status updates and other interactions. Because some servers are not configured correctly to handle making HTTP queries, I've included a toggle so that you could switch WP to Twitter to make queries on HTTP instead of HTTPS.

    As of January 14th, 2014, Twitter has shut off HTTP access to their API. 403 errors will now be returned when an HTTP query is made, and your status update will be rejected.

    If you have been dependent on HTTP support, you'll need to talk to your hosting company about fixing the problem. I'm afraid that there's nothing I can do.

    https://dev.twitter.com/discussions/24239

    http://wordpress.org/plugins/wp-to-twitter/

  2. mundomariah
    Member
    Posted 7 months ago #

    Thanks. I had http and it seems my server supports https too.

  3. Jai_wordpress
    Member
    Posted 7 months ago #

    Hi

    I have been using the WP-To-Twitter plugin in my Word Press blog for almost a year, and now it has stopped working. As the twitter is not supporting http anymore I just want to know what options do I have. Do I need to install SSL certificate on my server in order to get it working again ?

    Your help is much appreciated.

    Many Thanks

  4. Joe Dolson
    Member
    Plugin Author

    Posted 7 months ago #

    No, you don't need an SSL certificate, but your server needs to be able to communicate over the HTTPS protocol. If you don't know how to change that, you'll need to communicate with your host.

  5. Jai_wordpress
    Member
    Posted 7 months ago #

    we are hosting the website on our own web server and the word press is under our main web site. for example: http://www.website.com/wordpress.

    So do I need to ask our System Administrator to allow our web server to communicate over https protocol? is it just making some changes in the Firewall?

  6. Joe Dolson
    Member
    Plugin Author

    Posted 7 months ago #

    I can't really answer that question without knowing more about your server. Turn on OAuth debugging in WP to Twitter, get the full data from your attempt to communicate with Twitter, then talk to your system administrator. They should be able to solve the issue.

    It varies - it can be a problem with certificate verification, with open ports, firewalls, etc.

  7. timjal
    Member
    Posted 6 months ago #

    At the risk of asking a silly question, where is the toggle you added?

    I cannot see it in my WP to Twitter settings anywhere and have had the error for a long time now.

    Please help!

  8. Joe Dolson
    Member
    Plugin Author

    Posted 6 months ago #

    I've removed it. It used to be part of the plugin, but in 2.8.1 I removed it, since it no longer served any purpose.

    If you're having a related issue,please start a new support thread.

  9. timjal
    Member
    Posted 6 months ago #

    I tried to contact you directly through the plugin support though my blog. Hopefully, that came through to you.

    If not, when I'm next home, I'll post the issues here too.

  10. Joe Dolson
    Member
    Plugin Author

    Posted 6 months ago #

    I don't see it, but I don't know what name, email, or site I should be looking for, so it's hard to say. I respond to every email support message I get, but there are many reasons for them to sometimes not get to me.

  11. timjal
    Member
    Posted 6 months ago #

    I will check when I'm home.

    If it helps, my name is Tim and the blog is about art nudes. It was sent yesterday.

  12. Joe Dolson
    Member
    Plugin Author

    Posted 6 months ago #

    I don't see that request, and it's not in my spam filters, either. Can't say why; but it didn't get to me, for whatever reason.

  13. jclandin
    Member
    Posted 6 months ago #

    Hi Joe,

    I'm another affected for the "Error 403:..." while trying to send tweets. The weird thing is that everything worked fine until Feb 7st (four days ago) when those errors started. I thought that if WP-to-twitter worked since Jan 14th my server was able to use https.

    "Check support" succesfully contacts goo.gl shortening service and fails to submit an update to twitter. My server time and Twitter time difference is only six seconds. Editing a post and clicking "Tweet this" works fine.

    Before opening a support thread I wanted to see the OAuth connection debugging data... but I can't find it although "Get Debugging Data for OAuth Connection" is checked. Where is that information? Any idea about where to look why tweets aren't being automatically published?

    Thanks,
    Juan Carlos

  14. Joe Dolson
    Member
    Plugin Author

    Posted 6 months ago #

    Please, Please, Please: Start your own support threads. It is not at all helpful to me to try and manage multiple support requests in the same thread. You may believe that you're experiencing the same issue, but it's actually quite unlikely that you are.

    Please post a new support thread.

  15. Joe Dolson
    Member
    Plugin Author

    Posted 6 months ago #

    FYI, you can only see the OAuth debugging data when you make a connection to OAuth, because it's a data exchange that only happens in that circumstance. Disconnect from Twitter and reconnect to see those interactions.

  16. jclandin
    Member
    Posted 6 months ago #

    Ok. Sorry...

  17. timjal
    Member
    Posted 6 months ago #

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.