WordPress.org

Ready to get started?Download WordPress

Forums

(TwentyTwelve) Roles - Author - no go (9 posts)

  1. Qjoobsian
    Member
    Posted 1 year ago #

    I'd like to add a person to the site as an Author, to post some messages now and then.

    I guessed it would be as simple as > goto the admin area >
    Users > Add new > Fill in all required fields > Pick a role (Author) > Add new user > And that's it.
    After doing so, I asked the new Author to login with his Author name and password but the new author is referred back to the homepage without having the possibility to add a post all.

    What's going wrong here. I read things about phps and Loops. But it's still not clear to me.

  2. leejosepho
    Member
    Posted 1 year ago #

    Have your author try this kind of login link and see what happens:
    http://yoursite.xyz/wp-login.php?no-redirect=true

    And if you might ever want to set some specifics for various users or roles, you might take a look at a plugin called "Peter's Login Redirect".

  3. Qjoobsian
    Member
    Posted 1 year ago #

    Ok thx, I understand there is more to it than just add a user and go.
    What about the Loop?

  4. Qjoobsian
    Member
    Posted 1 year ago #

    @leejosepho, the login link you suggested does not to the trick. sorry

  5. leejosepho
    Member
    Posted 1 year ago #

    I did not know whether it would, but now we both know. My own problem at first, however, was the opposite of yours since I wanted everyone but an admin going only to the front of the site.

  6. Qjoobsian
    Member
    Posted 1 year ago #

    Okay, I see. Feel free if you have any other suggestions

  7. Qjoobsian
    Member
    Posted 1 year ago #

    Anyone else who can help.? Ineed to get the Author function up and running however adding the user Author in the Admin environment does not cover this.
    Is it not just that straight forward?
    Looking forward to any replies that can give me a push in the right direction.

  8. leejosepho
    Member
    Posted 1 year ago #

    Take a look through all your Dashboard > Settings and at any plugin settings you might have that might be re-directing anyone anywhere. Beginning from whatever WordPress defaults I used to have, I now use "Peter's Login Redirect" (plugin) and "WP Admin No Show" (plugin) along with a little from "Theme My Login" (plugin) to control all of that perfectly for me. However, it sounds to me like you might have something odd going on, and I hope someone else can help you sort that out.

    Ah, and it just struck me: Check to see whether "Show Toolbar when viewing site" is checked in your author's profile.

  9. Qjoobsian
    Member
    Posted 1 year ago #

    Ok, i will start to check if any of the Login plugins you suggested makes a difference. Although i mostly try to keep the install as clean as possible to avoid too much plugins that could cause inteference in one way or the other. Thx for ur help so far.
    I hope some of the other WP addicts have a possible solition.

Topic Closed

This topic has been closed to new replies.

About this Topic