WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Twentyeleven: #page background doesn't work on individual posts/ categories. (4 posts)

  1. ddss
    Member
    Posted 2 years ago #

    Hi there,

    I'm working on http://blog.dacesita.com which is a Twentyten based blog integrated in root of http://www.dacesita.com The goal is to match the blog to the website.

    I have created a child theme.

    I added a background image to #page ID:

    '#page {
    background: url(homepage04.jpg) repeat-x left bottom;
    }'

    works excellent... ...only for the 'home' site of blog - http://blog.dacesita.com

    If I click on a category, for instance, http://blog.dacesita.com/?cat=1 the background picture doesn't show up in its entire size and the area that is supposedly identified as #main area (I use chrome's 'inspect element' for checking that out) remains without the background image.

    For the example post at http://blog.dacesita.com/?p=1 the background picture displays only under the comment form.

    In both cases interestingly, the image displays for a moment when the page is loaded.

    any ideas will be appreciated,
    D.

  2. Mohd Rafie
    Member
    Posted 2 years ago #

    I suspect that you need to put a background colour value as below:

    #page {
    background: #fff url("homepage04.jpg") repeat-x left bottom;
    }
  3. ddss
    Member
    Posted 2 years ago #

    That's amazing, Mohdrafie, thank you! Only thing was that the image has to be without '"'

  4. Mohd Rafie
    Member
    Posted 2 years ago #

    You can take it out if you wish ;)

    #page {
    background: #fff url(homepage04.jpg) repeat-x left bottom;
    }

Topic Closed

This topic has been closed to new replies.

About this Topic