WordPress.org

Ready to get started?Download WordPress

Forums

twentyeleven child theme partially works on ipad (8 posts)

  1. psychill
    Member
    Posted 1 year ago #

    Hi there,

    My child theme of twentyeleven works in IE (6-8), safari, FF and chrome, but has strange behaviour on mobile safari (iPad and iPhone).

    On the main page, the css is working properly and it looks like this:
    http://www.jorisschaap.nl/test/wp-content/themes/twentyeleven-jorisschaap/ipad.PNG

    On all other pages, the css of the wrapper appears to break down.
    http://www.jorisschaap.nl/test/wp-content/themes/twentyeleven-jorisschaap/ipad_fail.PNG
    Any ideas on how to fix this?

  2. Andrew
    Forum Moderator
    Posted 1 year ago #

    Look at applying overflow: hidden; to your HTML element which contains the background image.
    Resource on overflow.

  3. psychill
    Member
    Posted 1 year ago #

    Hi Andrew,

    Thanks, but in this case the overflow is not my concern. It is the fact that the css of the 'wrapper' - which is a separate css file for the black strip - seems to not be loading at all. And the fact that only ios devices seem to be bugged.

    Strangely, the wrapper.css does load equally on all pages (as chrome tells me).

  4. Andrew
    Forum Moderator
    Posted 1 year ago #

    Can you link the problematic web page? It's difficult for forum volunteers to recommend fixes otherwise.

  5. psychill
    Member
    Posted 1 year ago #

    Hi Andrew,

    Sorry, I totally forgot. It's about http://www.jorisschaap.nl/test

  6. Andrew
    Forum Moderator
    Posted 1 year ago #

    I've looked at page, http://jorisschaap.nl/test/?page_id=93 and it seems your wrapper element is loading. Perhaps I've misunderstood the problem, can you again specify?

  7. psychill
    Member
    Posted 1 year ago #

    Yes, the wrapper element is loading on all pages, and on all devices.

    The accompanying css file, wrapper.css, which specifies the attributes for that wrapper, loads on all pc browsers. However, on iOS devices (mobile safari, e.g. ipad and iphone), the css seems to be loading on the homepage, but not on all the other pages (look for screenshots in the first post).

    Maybe it has something to do with the fact that I use frontpage.php, or wp-supersized for the front page, but I cannot quite get the hang of where to look for a solution.

    It's quite complicated, I hope my elaboration explains it more clearly?

  8. psychill
    Member
    Posted 1 year ago #

    I'm working on it, it seems to be something with the css precedence.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags