WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] twenty twelve hyperlink does not open in same window (9 posts)

  1. lstueck
    Member
    Posted 1 year ago #

    All of my hyperlinks open up in a new window. I am using the Twenty Twelve theme. The code is correct.

    My site is: lstueck.com

    Any help would be appreciated.

  2. leejosepho
    Member
    Posted 1 year ago #

    Maybe your browser is doing that? All of your site remains in one tab for me.

  3. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    <a class="link_text" href="http://lstueck.com/wp-content/uploads/DSC2587-bw.jpg" target="_blank"> is in the source code. All images have target=_blank" which is why they are doing what they are doing.

  4. lstueck
    Member
    Posted 1 year ago #

    Thank you kmessinger. I found the code you listed by "view page source" command in my browser. When I created the link I simply added an image to a page and used the link icon and left unchecked "open link in a new window/tab" box. After assigning the link the text shows the following:

    I've tried to edit the code within the page text without success.

    I understand I need to find and change the target="_blank" to target"_self"

    Embarrass to ask; where do I find the editable code?

  5. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    If they are in post or pages you can go to the dashboard and look at all posts or all pages and for which ever it is, mouse over it and click on edit.

    Then on the visual screen click on the graphic and then click the link button so you can edit the link. You can also click on the edit button on the graphic itself and change the link there. You can also edit the code in the text tab.

  6. lstueck
    Member
    Posted 1 year ago #

    I've done all that. The code is written to open in same window. No matter what I do to edit the link it always opens in a new window.

    I was hoping to access the code you originally pointed out to me i.e. the entire code and not just what is shown under "text" under Page.

    Could be something embedded in the theme?

  7. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Have you checked your local browser settings?

  8. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    Disable all your plugins and see what happens. If the result is good, enable them one-by-one until you find that one that is causing this action.

  9. lstueck
    Member
    Posted 1 year ago #

    Thank you everyone. I thought I disabled my plugins once before - who knows. Tried it again and it solved the problem. Slowly brought back the plugins I used to build my site and deleted the rest. Still works.

    WordPress is wonderful and I have only just begun.

    Appreciate the help. Don't be surprised if you see in a future post.

Topic Closed

This topic has been closed to new replies.

About this Topic