WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Twenty Ten header image and Admin panel images not showing (14 posts)

  1. lauraupcott
    Member
    Posted 3 years ago #

    I just installed WordPress on a sub domain. When I load my site the header image of the Twenty Ten theme is missing (just a blank rectangle with a red x). Also when I log into my wp-admin dashboard the icon image beside the site name in the top left corner also displays a red x. The buttons in the Quickpress admin panel also show red x's.

    I checked File Manager and all of the header images are there. I don't have any plugins activated. Actually I haven't done anything with the site except install WordPress. This is actually my second installation attempt because the the problem happened the first time too.

    How can I fix this and get the images to display? The site address is http://www.lauraupcott.com.

  2. govpatel
    Member
    Posted 3 years ago #

    I just installed WordPress on a sub domain.

    Looks like you images are looking for file here
    http://lauraupcott.com/wp-content/themes/twentyten/images/headers/path.jpg

    That is root and not subdomian did you move files and folders in subdomain name.

    the url you have in post is not subdomian name.

  3. datasoftict
    Member
    Posted 3 years ago #

    Hi,

    The directory listing shows that the files are in the right place, and if I type in http://lauraupcott.com/wp-content/themes/twentyten/images/headers/path.jpg to my browser I can see the image, same as I can with my own site. So the image is there.

    If you go into the admin panel and enter themes > header do you get any thumbnail images there?

    Can you check that your path names in your 'settings' point to your current URL

    It is strange as the image is there - we can see it if we type in the full URL, but it doesn't display so WP can't 'see' it.

    How did you set up WP, did you ftp all the files to the site? If so it might be worth checking permissions on the images directory. As a quick check it might be worth selecting another theme from the wordpress directory, activating it. Once in the new theme delete twenty ten. Once you have done this (a few minutes at most) go to themes > install themes and use the search box to find twenty ten (It finds it - I have just checked) and install the twenty ten again.

    Why your dashboard images have gone is another question. These come from wp_admin/images and should be hard coded.

    See if a re-install of the theme 'jogs' the system. Remember to de-activate any plugins you may have first.

  4. lauraupcott
    Member
    Posted 3 years ago #

    Hi govpatel, thanks for responding to my question and checking out the broken image link. To answer your question, the URL looks like a root domain but it's in a subdomain folder. Hostgator allows me to display subdomains as if they are in a root directory.

  5. govpatel
    Member
    Posted 3 years ago #

    what about urls in Settings General what have set them as.

  6. lauraupcott
    Member
    Posted 3 years ago #

    Hi datasoftict, I really appreciate that you took the time to look into my problem.

    No, the thumbnail images do not show in the admin panel themes > header. I checked the URL settings and they are correct.

    I set up WP from within Hostgator using Fantastico Deluxe. I think this may be the key because I set up another WP site on a different subdomain in the same Hostgator account that works fine. Maybe Fantastico installs don't work on subdomains in Hostgator?

    As you suggested, I'll test this by uninstalling the Fantastico version WP. Then I will try a manual install in the same subdomain.

    I'll let you know if this works.

    Thanks again for your help!

  7. lauraupcott
    Member
    Posted 3 years ago #

    govpatel, the URLs in my Settings General are both http://lauraupcott.com.

    I used Fantastico for my install. I'm going uninstall and then try a manual install to see if that fixes the problem.

  8. govpatel
    Member
    Posted 3 years ago #

    As fatastico can only install in a folder or a root so manual install will be best way to go.

  9. lauraupcott
    Member
    Posted 3 years ago #

    I just uninstalled the Fantastico version of WP. Then I manually reinstalled WordPress to the same subdomain. I'm sorry to say that the images are still broken. So I guess Fantastico wasn't the problem after all.

    Next I will try datasoftict's idea of uninstalling and re-installing the theme to see if this 'jogs' the system in to displaying the images.

  10. lauraupcott
    Member
    Posted 3 years ago #

    I just tried uninstalling the Twenty Ten theme. Then I installed a different theme. Then I deleted the Twenty Ten theme. Then I reinstalled Twenty Ten. The images are still broken.

    Next I will try contacting Hostgator to see if they might have some insight.

    Thanks again for all of your troubleshooting ideas.

  11. govpatel
    Member
    Posted 3 years ago #

    In Settings general site url try your subdomainurl as that is where all your files and folders are.

    After all subdomian name is folder on server is redirecting.

  12. lauraupcott
    Member
    Posted 3 years ago #

    The missing images issue was resolved by Chad B. at Hostgator tech support. He figured out that the images were being blocked by hotlink protection and he fixed it! The technical support at Hostgator is excellent. I really appreciate the input from datasoftict and govpatel too. The WordPress.org community is awesome.

  13. govpatel
    Member
    Posted 3 years ago #

    Glad to know that your problem is solved.

  14. datasoftict
    Member
    Posted 3 years ago #

    Glad to help.

Topic Closed

This topic has been closed to new replies.

About this Topic